Bluetooth Sound Issue

Announcements and discussion regarding the Deep Island Alcugs Shard.

Moderator: diafero

Bluetooth Sound Issue

Postby Lauritz » Thu Sep 24, 2020 2:57 pm

I have no sound when logged into the game using my Bluetooth headset. This has been going on for a couple of weeks now and I can't figure out what has changed or what the solution is.
When I run the Deep Island (DI) Shard using the speakers on my laptop everything works, sound is great, no issues.
When I enable my Bluetooth Headset and then start the game the sound plays while the game is loading but once my avatar appears there is no sound. If I switch applications while the game is still running I still have no sound. If I go into the Sound Settings on my computer it graphically shows the intensity of the sound varying so the sound is being received but it is not coming out of my headset. If I run a test of the headset sound from within the Sound Control Panel with the game running there is no sound from my headset yet I can see a graphical indication on the sound bars in Sound Settings and the Sound Control Panel that the test sound is being played.
I have no issues with any other programs including all the other URU shards (MOULa, ToC, Gehn, UAM, Minkata or even when playing offline using Drizzle.
I have considered uninstalling and reinstalling DI but would rather exhaust all other possible solutions first.
I am playing these game on an Alienware 17 laptop running Windows 10.
Any help is much appreciated.
Thank you for your time.
Lauritz
Lauritz
 
Posts: 2
Joined: Tue Feb 28, 2012 10:21 pm

Re: Bluetooth Sound Issue

Postby Sirius » Fri Sep 25, 2020 1:41 am

I suppose your headset has a built-in microphone ? For some reason, most Bluetooth devices on Windows can't both record and play audio, which results in the sound cutting for the whole OS. I'm not sure why Deep Island would use the mic since the voice chat is broken in this version of the game, but who knows, maybe it attempts to initialize the mic when the game starts...
Other versions of the game are either offline or had the code handling audio rewritten, which might explain the difference. (Although theoretically UAM uses the same version of the engine as DI, so go figure...)
Try right-clicking the audio icon in the taskbar, opening the audio options, and manually disable microphone input for your headset. The game's audio should work again, assuming the mic was the issue.
User avatar
Sirius
 
Posts: 1320
Joined: Mon Jul 26, 2010 4:46 am
Location: France

Re: Bluetooth Sound Issue

Postby Lauritz » Fri Sep 25, 2020 3:33 pm

Sirius,
That did it!
My Bluetooth headset (Bose QC35) has a built in microphone. I disabled it, leaving my computer's microphone enabled, started DI and all the sound was there. I then re-enabled the Bluetooth mic and the sound disappeared. I even disabled the Bluetooth mic while DI was running and the sound came back. Strange that the DI sound would be affected only by my Bluetooth mic in the headset.
In the past, when I was using my headset and the sound was working, I bet the computer wasn't using the mic from the headset but using it from the computer and I just didn't realize it. So when the computer, for some reason, switched to the Bluetooth mic and the sound disappeared I thought it was something in DI that changed. As it turns out, it was my computer and an unobservant me.
I thank you for your brilliant help. I never would have thought of this solution.
Lauritz
Lauritz
 
Posts: 2
Joined: Tue Feb 28, 2012 10:21 pm


Return to Deep Island

Who is online

Users browsing this forum: Bing [Bot] and 4 guests