Dirtsand on a VPS

Announcements and discussion regarding any projects related to Cyan Worlds' Plasma Engine including (but not limited to) CyanWorlds.com Engine, Drizzle, OfflineKI, PyPRP, and libHSPlasma.

Re: Dirtsand on a VPS

Postby Surta » Tue May 12, 2020 8:51 am

Whooooooooo hoooooooooooooooo! You are so right!! I checked the build\Release at first and was about to post "nah nothing" but it's sure there, in bin :D Thank you so much for getting me this far!!!

So now what is next, I take it I still need to do "stuff" with it to make it external? Or is that all taken care of? Again, my deepest gratitude, you truly have been awesome!

Edit: and, I'm IN!!!! In my own server!!! It worked! I'm so excited right now, thank you so very very much Hoikas (and others behind the scenes), I'm sure I will have more questions but for now I'm so very happy!
Surta
 
Posts: 55
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Surta » Wed May 13, 2020 9:16 am

You knew I'd be back, right? :D I'm running into two issues (one of my own doing), hopefully they'll be easy to resolve.

First, although I can get in the game now, create an avatar and run around Relto, the hood and Gahreesen (through the stone), I can't pick up my KI. The hotspot appears, but when I click it, it disappears and nothing happens. Likewise with the pillar to the desert, I can click it, but it won't open. Same with links in Nexus, closet, etc. Is that a setting I need to change? Oh I forgot to mention that I'm using the SDL list from H-uru/moul-scripts but I did get a server error (something about avatar customization SDL being wrong) the first time I logged in.

Second, Tsar Hoikas, I owe you an apology. When I cleaned out the Github folder, I must have accidentally deleted the rest of the githubs, including moul_utils. Of course I cloned it back, but now when I run manifest.py I get "ImportError: No module named PyHSPlasma". I remember you told me it's part of libhsplasma, so I cloned that and tried to build it according to the instructions. That one tells me

Could not find a package configuration file provided by "string_theory"
(requested version 2.0) with any of the following names:
string_theoryConfig.cmake
string_theory-config.cmake


Of course then I cloned string_theory and ran it with the new instructions for Windows, which seems to "do something" (it finishes without errors), but I still can't install libhsplasma because it keeps telling me that it needs string_theory - and thus can't run manifest.py any longer.

I know I had it running in the past, but I don't remember going through all these actions at all. What am I missing this time? :oops:
Surta
 
Posts: 55
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Tsar Hoikas » Fri May 15, 2020 4:26 pm

I think you'll want to adjust the libHSPlasma build to use the devlibs that were downloaded for CWE.

I am more concerned with why the KI machine is not working correctly. You might want to examine the python.0.log file in %LOCALAPPDATA%\Uru Live\log for any tracebacks.
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 2004
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Dirtsand on a VPS

Postby Surta » Fri May 15, 2020 6:30 pm

Thanks so much for all your help Hoikas, I can't say that enough. So, first... please realize I'm but a humble beginner... I understood what you meant by devlibs that were downloaded for CWE, since I only recently downloaded those when I created the client. I unzipped the files in the libHSPlasma folder but that is where I am lost... what comes next? :oops:

Second, here is the log file of me creating an avatar, then trying the desert pillar and visiting Gahreesen through the neighborhood. Hopefully you'll be able to see what's wrong... I feel we are sooo close though! I know it seems like we've gone backwards a few times but this is the first time that I have a full blown data server, a client that works with it and actually managed to get into the server without major crashes... a HUGE step forward for sure!
Attachments
log.zip
(75.55 KiB) Downloaded 8 times
Surta
 
Posts: 55
Joined: Fri Mar 29, 2019 1:13 pm

Previous

Return to Plasma Development

Who is online

Users browsing this forum: No registered users and 3 guests

cron