Import errors

Announcements and discussion regarding any projects related to Cyan Worlds' Plasma Engine including (but not limited to) CyanWorlds.com Engine, Drizzle, OfflineKI, PyPRP, and libHSPlasma.

Re: Import errors

Postby Robert The Rebuilder » Wed Mar 26, 2008 7:31 am

Fritz: do you get this error when using the latest plugin code from subversion?
Can we rebuild it? Yes, we can - here's how.

MOULagain KI# 1299

Myst Movie coming soon - spread the word!
User avatar
Robert The Rebuilder
 
Posts: 1383
Joined: Sat Sep 29, 2007 7:24 am
Location: Virginia, US

Re: Import errors

Postby Mystic2008 » Wed Mar 26, 2008 9:50 am

hi
my problem is myst v import error :cry:

import error myst.age and Descent.age

se here :cry:
Code: Select all
Traceback (most recent call last):
  File "<string>", line 145, in open_file
  File "<string>", line 90, in import_age
  File "C:\Programme\Blender Foundation\Blender2\.blender\scripts\alcresmanager.
py", line 209, in import_all
    scn.data.import_all(scene)
  File "C:\Programme\Blender Foundation\Blender2\.blender\scripts\alc_ObjClasses
.py", line 149, in import_all
    o.data.import_all(scene)
  File "C:\Programme\Blender Foundation\Blender2\.blender\scripts\alc_ObjClasses
.py", line 266, in import_all
    plSimulationInterface.Import(self,root,obj)
  File "C:\Programme\Blender Foundation\Blender2\.blender\scripts\alc_ObjClasses
.py", line 561, in _Import
    simi.data.import_obj(obj,scnobj)
AttributeError: pRaw instance has no attribute 'import_obj'


this is from myst.age

Code: Select all
Traceback (most recent call last):
  File "<string>", line 145, in open_file
  File "<string>", line 90, in import_age
  File "C:\Programme\Blender Foundation\Blender\.blender\scripts\alcresmanager.p
y", line 195, in import_all
    self.load()
  File "C:\Programme\Blender Foundation\Blender\.blender\scripts\alcresmanager.p
y", line 126, in load
    self.prp.read(f)
  File "C:\Programme\Blender Foundation\Blender\.blender\scripts\alcprpfile.py",
 line 576, in read
    obj.read(buf)
  File "C:\Programme\Blender Foundation\Blender\.blender\scripts\alcprpfile.py",
 line 374, in read
    o.read(buf,offset,size)
  File "C:\Programme\Blender Foundation\Blender\.blender\scripts\alcprpfile.py",
 line 283, in read
    self.data.read(buf)
  File "C:\Programme\Blender Foundation\Blender\.blender\scripts\alc_MatClasses.
py", line 2104, in read
    mipmap.read(stream,0) # "Really" is set to 0, to avoid reading hsKeyedObject
 code
  File "C:\Programme\Blender Foundation\Blender\.blender\scripts\alc_MatClasses.
py", line 1604, in read
    data.read(stream)
  File "C:\Programme\Blender Foundation\Blender\.blender\scripts\alcdxtconv.py",
 line 217, in read
    raise RuntimeError, "Invalid DXT size %ix%i"%(self.w,self.h)
RuntimeError: Invalid DXT size 755515400x1630350637


this from Descent.age

help pleas :cry:
soory for my english
thanks for all help me
Mystic2008
 
Posts: 1
Joined: Tue Mar 25, 2008 5:00 am

Re: Import errors

Postby Chacal » Wed Mar 26, 2008 10:55 am

As far as I know, the plug-in isn't compatible with Myst V.
Chacal


"The weak can never forgive. Forgiveness is an attribute of the strong."
-- Mahatma Gandhi
User avatar
Chacal
 
Posts: 2439
Joined: Tue Nov 06, 2007 2:45 pm
Location: Quebec, Canada

Re: Import errors

Postby Robert The Rebuilder » Thu Mar 27, 2008 6:14 am

Going back to Fritz's issue...

Blender only supports up to 16 materials for an object. There are objects in the Spy Room age that contain more than that. To fix this, I remove the extra materials from the imported object in plDrawableSpans.import_mesh() and print out a warning to this effect. So, the object will not look the same in Blender as it does in URU - but at least the import will continue.

I also noticed that the trunk version of alc_MatClasses.py throws an exception when importing a plLayerAnimation. That's because the size argument was removed from my previous fix of plLayerAnimation.read() and plLayerAnimationBase.read(). I fixed this as well.

These fixes can be found in contrib/RTR:

Would one of the plugin devs please review these changes and check them in?
Can we rebuild it? Yes, we can - here's how.

MOULagain KI# 1299

Myst Movie coming soon - spread the word!
User avatar
Robert The Rebuilder
 
Posts: 1383
Joined: Sat Sep 29, 2007 7:24 am
Location: Virginia, US

Re: Import errors

Postby Frits » Fri Mar 28, 2008 6:29 am

Thanks Robert for finding the answer.
I get an other error when trying to import an Uru age (make no difference wich age);

Image

Regards,
Frits <-- s, Fritz is someone else, I think :D
Frits
 
Posts: 132
Joined: Sun Feb 10, 2008 7:00 am

Re: Import errors

Postby Robert The Rebuilder » Fri Mar 28, 2008 9:02 am

Sorry about the name, Frits!

That error has been fixed in the PyPRP version that is in Subversion. To get this version, either:

- Download a subversion client and check out http://svn.guildofwriters.com/pyprp/trunk/src/, or
- Use your web browser to go to http://svn.guildofwriters.com/pyprp/trunk/src/ and download each file individually

Hopefully, the devs will soon make a 1.3.1 release, so you wouldn't have to do either of the above.
Can we rebuild it? Yes, we can - here's how.

MOULagain KI# 1299

Myst Movie coming soon - spread the word!
User avatar
Robert The Rebuilder
 
Posts: 1383
Joined: Sat Sep 29, 2007 7:24 am
Location: Virginia, US

Re: Import errors

Postby Frits » Sun Mar 30, 2008 1:09 am

Thanks Robert, I think I dive into this, a lot of work though :shock:
Frits
 
Posts: 132
Joined: Sun Feb 10, 2008 7:00 am

Re: Import errors

Postby Robert The Rebuilder » Mon Mar 31, 2008 9:20 am

Good luck, Frits!

Again - could a PyPRP dev please check in these fixes to the trunk, to allow importing to function? And this time, please don't remove the size argument from the plLayerAnimation*.read() methods. That caused the exception we're now seeing with the code in trunk.

Robert The Rebuilder wrote:These fixes can be found in contrib/RTR:


[EDIT] Thanks for checking these in, Paradox!
Can we rebuild it? Yes, we can - here's how.

MOULagain KI# 1299

Myst Movie coming soon - spread the word!
User avatar
Robert The Rebuilder
 
Posts: 1383
Joined: Sat Sep 29, 2007 7:24 am
Location: Virginia, US

Re: Import errors

Postby GPNMilano » Wed Apr 23, 2008 3:57 pm

Hi, I was wondering if the new plugin is compatible with Myst V, and if not, are there plans to make the next version compatible.
You can't stop the truth. IC Blog
User avatar
GPNMilano
 
Posts: 1155
Joined: Mon Apr 21, 2008 5:50 am

Re: Import errors

Postby Paradox » Wed Apr 23, 2008 4:47 pm

GPNMilano wrote:Hi, I was wondering if the new plugin is compatible with Myst V, and if not, are there plans to make the next version compatible.


The plugin does not support anything other than PotS/CC at this point.

If you would like to add support, please feel free :D
"And one day I woke to find the future held no place for me. I was unwanted in a world, that with my hands I'd helped to build. Where once was honesty and pride, I now stand broken and alone."
Paradox
 
Posts: 1261
Joined: Fri Sep 28, 2007 6:48 pm
Location: Canada

PreviousNext

Return to Plasma Development

Who is online

Users browsing this forum: No registered users and 3 guests

cron