GoW PyPRP 1.3.1

Announcements and discussion regarding any projects related to Cyan Worlds' Plasma Engine including (but not limited to) CyanWorlds.com Engine, Drizzle, OfflineKI, PyPRP, and libHSPlasma.

Re: GoW PyPRP 1.3.1

Postby Nadnerb » Sat Apr 19, 2008 10:46 pm

Ok, this may have been caused by one of the new features in the update. I put in a change shortly after the release of 1.3.1 (the second consecutive release from hell so far :() but it's possible that may have fixed the problem with the lights.

http://svn.guildofwriters.com/pyprp/tru ... Classes.py

replace that file and tell me if it works.
Live KI: 34914 MOULa KI: 23247 Gehn KI: 11588 Available Ages: TunnelDemo3, BoxAge, Odema
Nadnerb
 
Posts: 1057
Joined: Fri Sep 28, 2007 8:01 pm
Location: US (Eastern Time)

Re: GoW PyPRP 1.3.1

Postby Aloys » Sun Apr 20, 2008 8:33 am

That works for me!
A lamp, a sun, and an area light in my test Age working fine. Thanks for the fix. :)
User avatar
Aloys
 
Posts: 1864
Joined: Sun Oct 21, 2007 7:57 pm
Location: France (GMT +1)

Re: GoW PyPRP 1.3.1

Postby Whilyam » Sun Apr 20, 2008 5:23 pm

Works for me too. Thanks. :D
User avatar
Whilyam
 
Posts: 1023
Joined: Sat Sep 29, 2007 5:55 pm

Re: GoW PyPRP 1.3.1

Postby Jojon » Mon Apr 21, 2008 2:17 am

Yaaay, that did it! *sings Brendyman's praise*
Jojon
 
Posts: 1116
Joined: Sun Sep 30, 2007 5:49 am

Re: GoW PyPRP 1.3.1

Postby andylegate » Mon Apr 21, 2008 7:01 pm

Can we please have the link to the trunk again, for those of us that would like to use the "bleeding edge" version? Thanks.

EDIT: I found it. http://svn.guildofwriters.com/pyprp

Still, you might want to post it again.
"I'm still trying to find the plKey for Crud!"
Image
Blender Age Creation Tutorials
3DS Max Age Creation Tutorials
User avatar
andylegate
 
Posts: 2348
Joined: Mon Oct 01, 2007 7:47 am

Re: GoW PyPRP 1.3.1

Postby Goofy » Thu Apr 24, 2008 8:51 am

ummm got a kinda problem here. I've been using version 1.3.0 for a time and have had little to no problems, but today I decided to use 1.3.1(unchanged from release) and I got the below.

Code: Select all
Compiled with Python version 2.5.
Checking for installed Python... got it!
Exporting c:\Program Files\Blender Foundation\Blender\.blender\homeage\pharts\lo
gictest.age ...
Args are e_age
['e', 'age']
Exporting age logictest
[AlcScript Parser]
Traceback (most recent call last):
  File "<string>", line 176, in open_file
  File "<string>", line 67, in export_age
  File "C:\Program Files\Blender Foundation\Blender\.blender\scripts\alc_AlcScri
pt.py", line 206, in _LoadFromBlender
    AlcScript.book = AlcScript(text)
  File "C:\Program Files\Blender Foundation\Blender\.blender\scripts\alc_AlcScri
pt.py", line 55, in __init__
    self.Read(text)
  File "C:\Program Files\Blender Foundation\Blender\.blender\scripts\alc_AlcScri
pt.py", line 67, in Read
    self.content = yaml.safe_load(text)
  File "C:\Python25\lib\site-packages\yaml\__init__.py", line 82, in safe_load
    return load(stream, SafeLoader)
  File "C:\Python25\lib\site-packages\yaml\__init__.py", line 66, in load
    return loader.get_data()
  File "C:\Python25\lib\site-packages\yaml\constructor.py", line 38, in get_data

    return self.construct_document(self.get_node())
  File "C:\Python25\lib\site-packages\yaml\composer.py", line 27, in get_node
    return self.compose_document()
  File "C:\Python25\lib\site-packages\yaml\composer.py", line 34, in compose_doc
ument
    node = self.compose_node(None, None)
  File "C:\Python25\lib\site-packages\yaml\composer.py", line 63, in compose_nod
e
    node = self.compose_mapping_node(anchor)
  File "C:\Python25\lib\site-packages\yaml\composer.py", line 106, in compose_ma
pping_node
    while not self.check_event(MappingEndEvent):
  File "C:\Python25\lib\site-packages\yaml\parser.py", line 95, in check_event
    self.current_event = self.state()
  File "C:\Python25\lib\site-packages\yaml\parser.py", line 425, in parse_block_
mapping_key
    if self.check_token(KeyToken):
  File "C:\Python25\lib\site-packages\yaml\scanner.py", line 116, in check_token

    self.fetch_more_tokens()
  File "C:\Python25\lib\site-packages\yaml\scanner.py", line 220, in fetch_more_
tokens
    return self.fetch_value()
  File "C:\Python25\lib\site-packages\yaml\scanner.py", line 579, in fetch_value

    self.get_mark())
yaml.scanner.ScannerError: mapping values are not allowed here
  in "<string>", line 4, column 14:
        daylength: 24.0
                 ^


Not sure what all that means. I haven't changed blender install. it's still what I had from the start. I noticed that alscript is mentioned :roll: I don't have any use for that atm so I don't have one. I also don't have any sounds atm(its just a test age.)

Is that they bug that others have talked about?
We keep moving forward,
openning up new doors and doing new things,
Because we're curious... and curiosity keeps
leading us down new paths

Walt Disney

Keep moving forward
Goofy
 
Posts: 162
Joined: Mon Oct 01, 2007 8:51 pm

Re: GoW PyPRP 1.3.1

Postby D'Lanor » Thu Apr 24, 2008 11:46 am

No, this is a bug we did not find because we all have alcscript. Looks like you pinned down the cause too... not having an alcscript.

Edit: You should always create a book before attempting an export. That will add a default empty alcscript. Without a book PyPRP cannot handle the Blender file. Nor should it, because without a book it is technically not an Uru age.
"It is in self-limitation that a master first shows himself." - Goethe
User avatar
D'Lanor
 
Posts: 1980
Joined: Sat Sep 29, 2007 4:24 am

Re: GoW PyPRP 1.3.1

Postby Goofy » Thu Apr 24, 2008 12:10 pm

well scratch what I said about not having one. Apparently I do, but its empty(no entrys) As far as I know it never had anything in it to begin with. Since I never use it at this point so never bothered to look at it. Only thing I changed was the sequence number.
Also this test age has had a book since just before 1.3.0. Its nothing complicated just a few objects w/materials and textures, lights. It exported fine with 1.3.0, but apparently something in 1.3.1 doesn't like it.
We keep moving forward,
openning up new doors and doing new things,
Because we're curious... and curiosity keeps
leading us down new paths

Walt Disney

Keep moving forward
Goofy
 
Posts: 162
Joined: Mon Oct 01, 2007 8:51 pm

Re: GoW PyPRP 1.3.1

Postby D'Lanor » Thu Apr 24, 2008 12:34 pm

I just found that if you create a book in v 1.3.1 the alcscript is not empty. It has a line in it:

# insert AlcScript code here

What you can try is adding a short line like that. Make sure it starts with a #
"It is in self-limitation that a master first shows himself." - Goethe
User avatar
D'Lanor
 
Posts: 1980
Joined: Sat Sep 29, 2007 4:24 am

Re: GoW PyPRP 1.3.1

Postby Nadnerb » Thu Apr 24, 2008 2:18 pm

Actually, you do have a book, and there is something in it. The line shown in the error log came from the yaml parser. "daylength: 24.0" is the third line in the default book file. Try looking at your book text file again, and try scrolling up this time. ;) The mapping values error is probably an indentation error in the book file.
Live KI: 34914 MOULa KI: 23247 Gehn KI: 11588 Available Ages: TunnelDemo3, BoxAge, Odema
Nadnerb
 
Posts: 1057
Joined: Fri Sep 28, 2007 8:01 pm
Location: US (Eastern Time)

PreviousNext

Return to Plasma Development

Who is online

Users browsing this forum: No registered users and 3 guests