CWE testing builds released

Announcements and discussion regarding any projects related to Cyan Worlds' Plasma Engine including (but not limited to) CyanWorlds.com Engine, Drizzle, OfflineKI, PyPRP, and libHSPlasma.

CWE testing builds released

Postby Branan » Sat Oct 22, 2011 9:02 pm

Shorah, everyone!

With Cyan's recent fixes to the licensing, I can finally share builds with you... so I'm going to.

To connect this build to Cyan's server, simply run plclient_moula.vbs. Please be aware that this is an "internal" development build, and contains features that could allow you to do some nasty things in public areas. Please experiment only in The Fun House, or in your private age instances. I take no responsibility if you trash your private instance, so I suggest you use The Fun House. Even though this build can connect to cyan's server, you must not test any new ages on their server. It will break things. If you want to test an age you will need to configure your own server or find a shard owner who can accommodate you

You'll need to copy over the data and sfx folders from Cyan's MOULagain in order for these to be useful. You may also need to run oalinst.exe to install the OpenAL runtime on your system.

Also note that it's impossible to use the included UruExplorer with Cyan's server - the patcher will overwrite it. It's included only to make it possible for someone to base a shard off of this build.

If you downloaded the initial release, please delete the OpenAL32.dll file included with that zip. it's corrupt and could cause new releases to fail to launch


Changelog
902D:
  • Fixed a crash in Max 2012 when adding RT lights
  • Shaved about 3ms off age load times
902C:
  • Fixed an issue where plasma layers were not properly saved in max files
902B:
  • Plugin has an Export entry in the Plasma menu now
  • A launcher script has been added to connect plClient to Cyan's server
  • A Python.pak for shard operators who want to use these UruExplorer builds is now included
Initial Release:
  • Better input support--you are now able to send international chat
  • Improved the cursors
  • Fixed corrupted jpegs
  • Prevent some remote code exploits by screening network messages
  • Add support for multiple servers through config file (server.ini)
  • Don't disable num lock
  • Eliminate common dead stop lag issues
  • LOTS of under-the-hood changes and fixes

The version of the code used for the latest build is available here
Image
Your friendly neighborhood shard admin
User avatar
Branan
Gehn Shard Admin
 
Posts: 694
Joined: Fri Nov 16, 2007 9:45 pm
Location: Portland, OR

Re: CWE testing builds released

Postby Metabasalt1 » Sun Oct 23, 2011 6:53 am

Branan
This is very cool. I tried the CWE client, and put the avi, sfx, and dat files from moula into your client. I got an error when i ran plclient. Some hex code and then crash. What do i need to do to get the client to run, and run my test dat files created with max 7 and the cyan plugin. It would also be nice to have this work on a MOSS server, so we could test our ages built in max 7 in an online moul environment.
Meta
Metabasalt1
 
Posts: 68
Joined: Fri Apr 25, 2008 6:03 pm

Re: CWE testing builds released

Postby kaelisebonrai » Sun Oct 23, 2011 9:24 am

You *might* need to download the MOUL-SCRIPTS stuff from https://github.com/H-uru/moul-scripts

This all should work with MOSS as well, as I understand - we just don't test with MOSS, we use DIRTSAND. =)
User avatar
kaelisebonrai
 
Posts: 849
Joined: Sun Feb 03, 2008 3:27 am
Location: Perth, Western Australia

Re: CWE testing builds released

Postby Luna » Sun Oct 23, 2011 9:26 am

You probably need these files : https://github.com/H-uru/moul-scripts/zipball/master, copy & replace the files you currently have with that.
Now you right click "PlClient.exe" and create a shortcut.
Right click this shortcut.
choose "Properties" and add the end of "Target" add "-LocalData"

This will make your client use your local updated python&data files.
Code: Select all
long longestTimeWithoutPlayingMoula = (new Date()) - (new Date(2014, 9, 26));
User avatar
Luna
 
Posts: 204
Joined: Fri Oct 08, 2010 12:21 am
Location: Il y a encore des pommes.

Re: CWE testing builds released

Postby Tsar Hoikas » Sun Oct 23, 2011 9:33 am

This release is really for more savy users at this point. More comprehensive instructions will be released later once we work around the issue of needing to give you the keys to the universe to do anything ;)
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 1900
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: CWE testing builds released

Postby Lehm » Tue Oct 25, 2011 8:30 pm

Has the plugin been confirmed to work in 2011? I'm using 2010, and supposedly plugins that are compatible with 2011 should work with 2010, but I'm getting an error.

Error code 127 - The specified procedure could not be found.
Lehm
 
Posts: 50
Joined: Fri Sep 28, 2007 11:12 pm

Re: CWE testing builds released

Postby Branan » Tue Oct 25, 2011 9:08 pm

I confirmed that it loaded, and that the menu items appeared to be where they should be. I'm not familiar with the max plugin, so I didn't test beyond the very basics.

Also, make sure you're using a 32-bit version of max. 64-bit versions still won't work with the plugin.
Image
Your friendly neighborhood shard admin
User avatar
Branan
Gehn Shard Admin
 
Posts: 694
Joined: Fri Nov 16, 2007 9:45 pm
Location: Portland, OR

Re: CWE testing builds released

Postby Lehm » Wed Oct 26, 2011 2:49 pm

Did a little searching seems error 127 typically means a plugin is not compatible with your version. Probably means it would have to be compiled with the 2010 sdk. Is there any chance of getting a 2010 version? I'd really like to check out the plugin, but there's pretty much no chance of me upgrading to 2011.
Lehm
 
Posts: 50
Joined: Fri Sep 28, 2007 11:12 pm

Re: CWE testing builds released

Postby Branan » Wed Oct 26, 2011 3:33 pm

It looks like the Autodesk student program does have 2010 available, so I'll add it to my build, along with 2012.

My build VM is misbehaving currently, but once I get it fixed I'll try to get some new plugins out.
Image
Your friendly neighborhood shard admin
User avatar
Branan
Gehn Shard Admin
 
Posts: 694
Joined: Fri Nov 16, 2007 9:45 pm
Location: Portland, OR

Re: CWE testing builds released

Postby I.Brattin » Wed Oct 26, 2011 7:46 pm

I am getting something weird. Max 2011 is not finding PlasmaMax2.ini.

Max says this "PlasmaMAX2.ini is missing or invalid"

I have it in the plugcfg directory where it's supposed to be, but it won't find it.
MOUL Again Ki #'s
I.Brattin - 777796
Jayden Halliwell (IC Explorer) - 54404
I.Brattin
 
Posts: 471
Joined: Sat Jan 31, 2009 3:06 pm

Next

Return to Plasma Development

Who is online

Users browsing this forum: No registered users and 2 guests

cron