Persoanal server problems

Announcements and discussion regarding any projects related to Cyan Worlds' Plasma Engine including (but not limited to) Engine, Drizzle, OfflineKI, PyPRP, and libHSPlasma.

Re: Persoanal server problems

Postby johnsojc » Wed May 16, 2012 5:36 pm

Branan wrote:
johnsojc wrote:I wish we could just chuck out all this old crappy software and start over fresh. :x

I keep threatening to do that, then I realize how much effort it actually is ;)

Not a job for just one or even a few people.

I've been tinkering with the idea of doing something with Dirtsand which works pretty well already but seems limited somehow... I can't seem to bring to light what is bothering me about it. For now I think just figuring out exactly how it works will give me some ideas. I primarily did database programming for most of my career but nothing recently... I am hopelessly obsolete in modern DB design. Too much trying to extend the life of legacy DB apps and not enough keeping up with the new stuff. :oops:
Posts: 246
Joined: Sun Dec 07, 2008 10:27 am

Re: Persoanal server problems

Postby Drake Collins » Tue Jun 26, 2012 3:25 pm

Another problem I had was the horrendous number if errors I got in my MOSS logs using the H'uru internal client. Failure to write nodes, blob size mismatches, other things I need to research to figure out just what the error is... The MOSS server also failed to remember my progress. Is this typical of using and internal client or could my MOSS setup be totally hosed?

The MOSS shard does not work well with Postgresql 9.x. Try downgrading to 8.4.
Drake Collins
Posts: 10
Joined: Sun Nov 28, 2010 7:12 pm

Re: Persoanal server problems

Postby Drake Collins » Sat Jun 30, 2012 9:41 pm


I have been trying to bring up a dirtsand shard using the latest pulls of moul-scripts, dirtsand, and Plasma. I am being stopped by "CustomAvatars".

If I run plClient without any switches, it will eventually fail with a popup that says "Failed to download manifest CustomAvatars".
The server displays:
Code: Select all
[File] requested invalid manifest /opt/dirtsand/data/CustomAvatars.mfs

If I run plClient with /LocalData, Dirtsand server segfaults with:
Code: Select all
[SDL] Requested invalid descriptor AvatarCustomization
[Vault] Warning: Could not find SDL descriptor for AvatarCustomization
[SDL] Requested invalid decriptor version 6 for Layer
Segfault at bin/dirtsand() [0x810d296]
    from bin/dirtsand() [0x810d333]
    from [0xb779a400]
    from bin/dirtsand(_ZNK2DS12StringBufferIhE4dataEv+0x6) [0x80ccf5a]
    from bin/dirtsand(_ZNK2DS6String5c_strEv+0x14) [0x80ccc8c]
    from bin/dirtsand(_ZNK2DS10StringHashclERKNS_6StringE+0x1d) [0x80f5961]
    from bin/dirtsand(_ZNKSt8__detail15_Hash_code_baseIN2DS6StringESt4pairIKS2_N3SDL5StateEESt10_Select1stIS7_ESt8equal_toIS2_ENS1_10StringHashENS_18_Mod_range_hashingENS_20_Default_ranged_hashELb0EE12_M_hash_codeERS4_+0x1b) [0x810146d]
    from bin/dirtsand(_ZNSt8__detail9_Map_baseIN2DS6StringESt4pairIKS2_N3SDL5StateEESt10_Select1stIS7_ELb1ESt10_HashtableIS2_S7_SaIS7_ES9_St8equal_toIS2_ENS1_10StringHashENS_18_Mod_range_hashingENS_20_Default_ranged_hashENS_20_Prime_rehash_policyELb0ELb0ELb1EEEixERS4_+0x1f) [0x80ff72f]
    from bin/dirtsand(_Z11dm_read_sdlP16GameHost_PrivateP18GameClient_PrivatePN4MOUL14NetMsgSDLStateEb+0x460) [0x80fa479]
    from bin/dirtsand(_Z15dm_game_messageP16GameHost_PrivateP21Game_PropagateMessage+0x29e) [0x80fbd60]
    from bin/dirtsand(_Z11dm_gameHostP16GameHost_Private+0x7d) [0x80fc695]
    from bin/dirtsand(_ZNSt12_Bind_resultIvFPFvP16GameHost_PrivateES1_EE6__callIvIEILi0EEEEvOSt5tupleIIDpT0_EESt12_Index_tupleIIXspT1_EEENS5_16__enable_if_voidIT_E4typeE+0x37) [0x810744f]
    from bin/dirtsand(_ZNSt12_Bind_resultIvFPFvP16GameHost_PrivateES1_EEclIIEEEvDpOT_+0x33) [0x810740d]
    from bin/dirtsand(_ZNSt6thread5_ImplISt12_Bind_resultIvFPFvP16GameHost_PrivateES3_EEE6_M_runEv+0x14) [0x8107378]
    from /usr/lib/i386-linux-gnu/ [0xb74e1007]
    from /lib/i386-linux-gnu/ [0xb7282d4c]
    from /lib/i386-linux-gnu/ [0xb7381ace]
Aborted (core dumped)

And the client dies with a "Net 6" error. 8-)

As near as I can tell AvatarCustomization wants to distribute some proprietary .prp files and we don't have license to do that. I am using the latest and greatest dat and sfx files from Cyan.
What the heek am I missing?
Drake Collins
Posts: 10
Joined: Sun Nov 28, 2010 7:12 pm

Re: Persoanal server problems

Postby Tsar Hoikas » Sat Jun 30, 2012 9:45 pm

According to the /LocalData segfault, the SDL files on the server are missing/not of the right version/corrupt. Make sure the client and server SDL files match, ensure the server SDL is decrypted, wipe the vault*, and try again 8-). As a stopgap for the manifest problem, you can touch a *.mfs file for each *.age file to squelch that error. Be warned that without file listings in the manifest, any client can connect with whatever data he wants to use, which can be somewhat dangerous for server stability.

* There's a clear_vault() function added to the postgres database
User avatar
Tsar Hoikas
Councilor of Technical Direction
Posts: 1932
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia


Return to Plasma Development

Who is online

Users browsing this forum: Google [Bot] and 1 guest