Flymode and vault modefieing?

Announcements and discussion regarding any projects related to Cyan Worlds' Plasma Engine including (but not limited to) CyanWorlds.com Engine, Drizzle, OfflineKI, PyPRP, and libHSPlasma.

Re: Flymode and vault modefieing?

Postby jamie_marchant » Thu Mar 15, 2012 8:49 am

Oh no I'm still haveing the above issue. This error may help:
---------------------------
Microsoft Visual C++ Debug Library
---------------------------
Debug Assertion Failed!

Program: ...Plasma\bins\Sources\Plasma\Apps\plClient\.\Debug\plClient.exe
File: C:\Users\Marchant\source\MOULa\Plasma\Sources\Plasma\PubUtilLib\plNetClient\plNetClientMsgHandler.cpp
Line: 260

Expression: SDL descriptor Personal missing, v=1

For information on how your program can cause an assertion
failure, see the Visual C++ documentation on asserts.

(Press Retry to debug the application)
---------------------------
Abort Retry Ignore
---------------------------
jamie_marchant
 
Posts: 96
Joined: Tue Feb 07, 2012 1:15 pm

Re: Flymode and vault modefieing?

Postby Branan » Thu Mar 15, 2012 9:38 am

that looks like the client can't find the sdl files. You'll need to either add them to a server manifest, or run the client with the '-localdata' switch. It won't use unencrypted SDL files without that switch.
Image
Your friendly neighborhood shard admin
User avatar
Branan
Gehn Shard Admin
 
Posts: 694
Joined: Fri Nov 16, 2007 9:45 pm
Location: Portland, OR

Re: Flymode and vault modefieing?

Postby jamie_marchant » Thu Mar 15, 2012 12:58 pm

I added "'-localdata" as a start up pramiter(before I had "/localdata") but I still have this error.
jamie_marchant
 
Posts: 96
Joined: Tue Feb 07, 2012 1:15 pm

Re: Flymode and vault modefieing?

Postby Luna » Fri Mar 16, 2012 1:05 am

Do you get any errors or warnings from the server? (as in , in the terminal the server is running in)
Code: Select all
long longestTimeWithoutPlayingMoula = (new Date()) - (new Date(2014, 9, 26));
User avatar
Luna
 
Posts: 203
Joined: Fri Oct 08, 2010 12:21 am
Location: There are apples.

Re: Flymode and vault modefieing?

Postby jamie_marchant » Fri Mar 16, 2012 6:32 am

Nope
jamie_marchant
 
Posts: 96
Joined: Tue Feb 07, 2012 1:15 pm

Re: Flymode and vault modefieing?

Postby Branan » Sun Mar 18, 2012 10:47 am

That error definitely means it can't find an SDL file, or you're using the wrong version of an SDL file.

So just to make sure: You have the unencrypted Gehn .sdl files in an SDL/ folder in the client, right next to dat/ and sfx/ and whatnot?
Image
Your friendly neighborhood shard admin
User avatar
Branan
Gehn Shard Admin
 
Posts: 694
Joined: Fri Nov 16, 2007 9:45 pm
Location: Portland, OR

Re: Flymode and vault modefieing?

Postby jamie_marchant » Sun Mar 18, 2012 2:42 pm

It appears I put the Genh SDls in the wrong place. I recopied them and now it works. Thank you very much.
jamie_marchant
 
Posts: 96
Joined: Tue Feb 07, 2012 1:15 pm

Previous

Return to Plasma Development

Who is online

Users browsing this forum: No registered users and 1 guest