Drizzle Issue

Announcements and discussion regarding any projects related to Cyan Worlds' Plasma Engine including (but not limited to) CyanWorlds.com Engine, Drizzle, OfflineKI, PyPRP, and libHSPlasma.

Drizzle Issue

Postby Charura » Tue Jul 12, 2016 2:21 pm

Just re-installed URU-CC and then also made a copy 'Drizzled' to an obscure location... Everything works great on the first try... Then I try to re-start it and it tells me that URU is already running... I have checked Task Manager, and there is no instance of URU running... Tried a shut-down and re-start.... Same thing... Tried a Complete shut-down, then re-started with the power button... Same thing... Did a Complete shut-down... Waited 10 minutes... Re-Started... URU will start one time on either the URU-CC install or the URU-CC 'Drizzled' install and then same thing happens... BTW URU-Moul(a) starts up just fine in all cases... Any ideas?

Mod Note: Please do not resurrect old threads.
Gehn Shard avvies: charura 10827 chickopee 142711 cannon belle 144577 char gearz 149794 teri dactyl 153077
Moul(a) Charura 55400 Chickopee 20089892 Cannon Belle 13686512 Char Gearz 706359 Teri Dactyl 12658065
Charura
 
Posts: 178
Joined: Wed Oct 14, 2009 9:26 am

Re: Drizzle Issue

Postby Sirius » Tue Jul 12, 2016 10:57 pm

I can't say I have ever experienced that issue to such degree. This happened just a rare few times on my PC, and killing the UruExplorer process in the task manager was always enough (and yeah, I'm used to launching Uru a lot, several times in a row, as well as making it crash very hard).

The fact that it affects both the standard and the Drizzled version is not surprising - since the base executable (UruExplorer.exe) is the same, a non-closed Uru version will prevent the other from starting. However I can't understand why launching only the standard CC version would cause the issue.
You mention it also affects the standard CC install - does that mean this CC install has the problem if you NEVER launched the Drizzled version since your computer's startup ? In which case it wouldn't be a Drizzle issue at all.

Otherwise, if the problem is started by the Drizzled install (and not the CC one), then it might have something to do with the widescreen patch working on a non-standard UruExplorer.exe. Did you apply this patch, and did you download the unofficial No-CD patch first ? Also, I seem to recall you're using the Steam version, right ?

(I know that's a lot of question, but I'm trying to narrow down the possibilities :) )
User avatar
Sirius
 
Posts: 957
Joined: Mon Jul 26, 2010 4:46 am
Location: France

Re: Drizzle Issue

Postby Charura » Wed Jul 13, 2016 12:41 pm

Many apologies to the Mod... :?

My install was from the CD's. I didn't install the widescreen patch and only used the drizzle version of the No-CD Patch. I did finally get the Drizzled version to work every time I start it, but the original install still gives me the 'URU.exe already running' thing. I'm going to try installing the GOG.com version for the 'Un-drizzled' version and see if that works... Will let you know...

EDIT: Gog.com version did the same thing so I change the shortcut to start @ URU setup instead of URU application on both drizzled and un-drizzled versions... Works for me every time now... I'm a happy camper :P Other than I have to look at the gears icon instead of the much better book icon....
Gehn Shard avvies: charura 10827 chickopee 142711 cannon belle 144577 char gearz 149794 teri dactyl 153077
Moul(a) Charura 55400 Chickopee 20089892 Cannon Belle 13686512 Char Gearz 706359 Teri Dactyl 12658065
Charura
 
Posts: 178
Joined: Wed Oct 14, 2009 9:26 am

Re: Drizzle Issue

Postby Sirius » Wed Jul 13, 2016 3:04 pm

Glad to hear it's solved ! :)

Uru can be a bit unstable on modern Windows versions. In my case it sometime crashes at startup depending of whether I run it using the graphic card or the integrated one. :shrug:

Also, you can change the icon of a shortcut by going into it's properties. Personally I usually bypass UruSetup entirely, and run UruExplorer directly using the iinit To_Dni trick.
User avatar
Sirius
 
Posts: 957
Joined: Mon Jul 26, 2010 4:46 am
Location: France


Return to Plasma Development

Who is online

Users browsing this forum: No registered users and 1 guest