Personal Dirtsand server Problems

Announcements and discussion regarding any projects related to Cyan Worlds' Plasma Engine including (but not limited to) CyanWorlds.com Engine, Drizzle, OfflineKI, PyPRP, and libHSPlasma.

Personal Dirtsand server Problems

Postby Nobby » Sun Mar 26, 2017 5:48 am

Hi,

I just set up a Dirtsand server on my personal home server. Everything seems to be working, I can log in, created a player but when I try to link into AvatarCustomization (direclty after creating a new player), the loading screen shows up, rotates for about 10 seconds and I get an Network error 5: Image
this is what the debug message looks like: Image

The dirtsand shell doesn't display any errors:
Code: Select all
ds-918> [Status] Running on 0.0.0.0/8080
[Lobby] Running on 0.0.0.0/14617
[Auth] 192.168.0.8/51635 logged in as admin {2a806dc5-ffbb-4c98-8191-7c327cada050}
[Auth] {2a806dc5-ffbb-4c98-8191-7c327cada050} signed in as admin (10130)

I really don't know, what the problem is.
XX_LIBRARY-NOT-FOUND :roll:
Nobby
 
Posts: 30
Joined: Thu Sep 02, 2010 4:03 am
Location: Gahreesen

Re: Personal Dirtsand server Problems

Postby Deledrius » Sun Mar 26, 2017 9:14 am

Your Dropbox images aren't showing for me. They might not be public?
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1013
Joined: Mon Oct 01, 2007 1:21 pm

Re: Personal Dirtsand server Problems

Postby Tsar Hoikas » Sun Mar 26, 2017 3:23 pm

Make sure that you've correctly set the game server address in dirtsand.ini
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 1798
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Personal Dirtsand server Problems

Postby Nobby » Sat Apr 01, 2017 11:59 am

Tsar Hoikas wrote:Make sure that you've correctly set the game server address in dirtsand.ini


Ths is my configuration:

Code: Select all
# Server encryption keys (See CryptKeys.txt for details on how to use these)
#Key.Auth.N = ...
#Key.Auth.K = ...
#Key.Game.N = ...
#Key.Game.K = ...
#Key.Gate.N = ...
#Key.Gate.K = ...

[Some keys generated by dirtsand]

# For Python/SDL
Key.Droid = 31415926535897932384626433832795

# EXTERNAL server addresses -- should probably point to this server for now
File.Host = localhost
Auth.Host = localhost
Game.Host = localhost

# Server address/port to bind to...  Leave commented to bind to any
# address on the default MOULa port (14617)
#Lobby.Addr =
#Lobby.Port = 14617

# JSON Server Status over HTTP.  Note:  Disabling the status server will
# also disable the welcome message below.
#Status.Enabled = true
#Status.Addr = localhost
#Status.Port = 8080

# Paths to server data
File.Root = /opt/dirtsand/data
Auth.Root = /opt/dirtsand/authdata
Sdl.Path = /opt/dirtsand/SDL
Age.Path = /opt/dirtsand/ages

# Postgres options -- You need to add a user before this will work
Db.Host = localhost
Db.Port = 5432
Db.Username = dirtsand
Db.Password = [...]
Db.Database = dirtsand

# The default Welcome message -- This can be changed while the server
# is running with the welcome command
Welcome.Msg = It's ALIVE!
XX_LIBRARY-NOT-FOUND :roll:
Nobby
 
Posts: 30
Joined: Thu Sep 02, 2010 4:03 am
Location: Gahreesen

Re: Personal Dirtsand server Problems

Postby Deledrius » Tue Apr 04, 2017 3:34 pm

I'm not sure, but it might be worth changing File.Host, Auth.Host, and Game.Host from localhost to the local IP address for your server. It looks like the auth is binding to the interface on all addresses, but perhaps the gameserver is not?
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1013
Joined: Mon Oct 01, 2007 1:21 pm

Re: Personal Dirtsand server Problems

Postby Nobby » Wed Apr 05, 2017 10:50 am

Deledrius wrote:I'm not sure, but it might be worth changing File.Host, Auth.Host, and Game.Host from localhost to the local IP address for your server. It looks like the auth is binding to the interface on all addresses, but perhaps the gameserver is not?

Thanks, that solved it!
I was able to configure my avatar, but directly after that, I got the next error:

Dirtsand's ouput:
Code: Select all
[SDL] Requested invalid descriptor AvatarCustomization
[SDL] Requested invalid decriptor version 6 for Layer
[SDL] Received an update for 'Map #638_anim' using an invalid descriptor!
[SDL] Requested invalid decriptor version 6 for Layer
[SDL] Received an update for 'Map #638_anim_KILightTurnOff' using an invalid descriptor!
[SDL] Requested invalid decriptor version 6 for Layer
[SDL] Received an update for 'Map #638_anim_KILightTurnOn' using an invalid descriptor!
[SDL] Requested invalid decriptor version 4 for clothing
[SDL] Received an update for 'Male' using an invalid descriptor!
[SDL] Requested invalid decriptor version 2 for MorphSequence
[SDL] Received an update for 'Med' using an invalid descriptor!
[SDL] Requested invalid decriptor version 2 for MorphSequence
[SDL] Received an update for 'High' using an invalid descriptor!


plClient's debug msg:
uerror_dbg_2.PNG
uerror_dbg_2.PNG (12.79 KiB) Viewed 341 times


Is that a client-side problem or still server-side?
XX_LIBRARY-NOT-FOUND :roll:
Nobby
 
Posts: 30
Joined: Thu Sep 02, 2010 4:03 am
Location: Gahreesen

Re: Personal Dirtsand server Problems

Postby Deledrius » Wed Apr 05, 2017 11:56 pm

I don't have time at the moment to check, but that looks like it might be that you're missing the SDL files in /opt/dirtsand/SDL? The current Dirtsand README (step 5) covers this, but I'm afraid that section is a bit confusing and definitely isn't as clear as it could be.
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1013
Joined: Mon Oct 01, 2007 1:21 pm

Re: Personal Dirtsand server Problems

Postby Tsar Hoikas » Thu Apr 06, 2017 12:54 pm

The first problem you had was that the server was telling the client to connect to localhost, where no URU server was running ;)

The second issue we have appears to be that your client is missing the decrypted SDL files inside the client SDL directory. Please ensure the appropriate SDL files are in that location and decrypted.
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 1798
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia


Return to Plasma Development

Who is online

Users browsing this forum: No registered users and 1 guest

cron