Windows 10 and plClient.exe issues

Announcements and discussion regarding any projects related to Cyan Worlds' Plasma Engine including (but not limited to) CyanWorlds.com Engine, Drizzle, OfflineKI, PyPRP, and libHSPlasma.

Windows 10 and plClient.exe issues

Postby J'Kla » Tue Sep 11, 2018 3:54 am

This is strange I am having an issue with plClient.exe

I was using Windows 7 Pro and I have had to upgrade to Windows 10 on my main PC because of some unrelated software needs.

So, I have the upgrade DVD I made when it was a free upgrade and I reluctantly moved to Windows 10.

I do have another desktop that’s still running Windows 7 Home and I can log into my Home LAN based dirtsand from that so I know that end is OK.

Initially the Upgraded Windows 10 was fine and I was able to use the dirtsand without issue in some ways it was slightly better in that appeared to load marginally quicker.

Then I had a flock of Windows 10 updates and ever since the plClient.exe fails at password it just switches off. No messages or anything. Actually, that’s wrong the first time I run it hangs at the little Getting Uru box and crashes if you do anything else and any subsequent attempts it does not even show that small crumb, it bombs out before I can even type in the password.

I can log into my dirtsand shard with Putty and CoreFTP.

I can use the same windows 10 to access MOULa which kind of proves that the DirectX and PhysX are fine. This fails for both Destiny and my own dirtsand installation.

Plus before I am asked yes I made the shortcut and set the -LocalData switch.

I have a second PC that was also fine but this one after its update decided that it was going to be a pain and stop all access until I reinstalled Windows 10, and that was the point at which plClient.exe stopped working.

The second PC was more catastrophic because it decided that in order to solve the issues it was having it would stop links to any installed software. It did not remove the software it just stopped them all working no uninstall and most have come back to life with a reinstall but it has been a pain.

I just hate being shafted by Microsoft.

I suspect it may be related to either Windows Firewall or Defender
User avatar
J'Kla
 
Posts: 891
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK

Re: Windows 10 and plClient.exe issues

Postby J'Kla » Thu Oct 04, 2018 3:47 am

OK time to look at MOSS
User avatar
J'Kla
 
Posts: 891
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK

Re: Windows 10 and plClient.exe issues

Postby Deledrius » Thu Oct 04, 2018 7:15 am

J'Kla wrote:OK time to look at MOSS


You are having a problem with your client, so you're changing the server?
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1184
Joined: Mon Oct 01, 2007 1:21 pm

Re: Windows 10 and plClient.exe issues

Postby J'Kla » Mon Oct 15, 2018 1:38 am

I am not getting anywhere with getting an answer as to why the client is not working on Windows10 tired of beating my head against the wall I figured I have at least learned something in building a dirtsand shard with a client that works with Windows7 and while I am waiting I may as well take a look at the MOSS shard option.

Just because I am looking at MOSS does not mean I am not still waiting for an answer on the dirtsand Windows10 client issue I just figure it may be worth looking for a new section of wall to beat my head against as there is an outside chance it is a slightly softer wall. :)

Are you suggesting it is not valid to try both?
User avatar
J'Kla
 
Posts: 891
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK


Return to Plasma Development

Who is online

Users browsing this forum: No registered users and 1 guest

cron