Windows 10 and plClient.exe issues

Announcements and discussion regarding any projects related to Cyan Worlds' Plasma Engine including (but not limited to) CyanWorlds.com Engine, Drizzle, OfflineKI, PyPRP, and libHSPlasma.

Windows 10 and plClient.exe issues

Postby J'Kla » Tue Sep 11, 2018 3:54 am

This is strange I am having an issue with plClient.exe

I was using Windows 7 Pro and I have had to upgrade to Windows 10 on my main PC because of some unrelated software needs.

So, I have the upgrade DVD I made when it was a free upgrade and I reluctantly moved to Windows 10.

I do have another desktop that’s still running Windows 7 Home and I can log into my Home LAN based dirtsand from that so I know that end is OK.

Initially the Upgraded Windows 10 was fine and I was able to use the dirtsand without issue in some ways it was slightly better in that appeared to load marginally quicker.

Then I had a flock of Windows 10 updates and ever since the plClient.exe fails at password it just switches off. No messages or anything. Actually, that’s wrong the first time I run it hangs at the little Getting Uru box and crashes if you do anything else and any subsequent attempts it does not even show that small crumb, it bombs out before I can even type in the password.

I can log into my dirtsand shard with Putty and CoreFTP.

I can use the same windows 10 to access MOULa which kind of proves that the DirectX and PhysX are fine. This fails for both Destiny and my own dirtsand installation.

Plus before I am asked yes I made the shortcut and set the -LocalData switch.

I have a second PC that was also fine but this one after its update decided that it was going to be a pain and stop all access until I reinstalled Windows 10, and that was the point at which plClient.exe stopped working.

The second PC was more catastrophic because it decided that in order to solve the issues it was having it would stop links to any installed software. It did not remove the software it just stopped them all working no uninstall and most have come back to life with a reinstall but it has been a pain.

I just hate being shafted by Microsoft.

I suspect it may be related to either Windows Firewall or Defender
User avatar
J'Kla
 
Posts: 900
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK

Re: Windows 10 and plClient.exe issues

Postby J'Kla » Thu Oct 04, 2018 3:47 am

OK time to look at MOSS
User avatar
J'Kla
 
Posts: 900
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK

Re: Windows 10 and plClient.exe issues

Postby Deledrius » Thu Oct 04, 2018 7:15 am

J'Kla wrote:OK time to look at MOSS


You are having a problem with your client, so you're changing the server?
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1197
Joined: Mon Oct 01, 2007 1:21 pm

Re: Windows 10 and plClient.exe issues

Postby J'Kla » Mon Oct 15, 2018 1:38 am

I am not getting anywhere with getting an answer as to why the client is not working on Windows10 tired of beating my head against the wall I figured I have at least learned something in building a dirtsand shard with a client that works with Windows7 and while I am waiting I may as well take a look at the MOSS shard option.

Just because I am looking at MOSS does not mean I am not still waiting for an answer on the dirtsand Windows10 client issue I just figure it may be worth looking for a new section of wall to beat my head against as there is an outside chance it is a slightly softer wall. :)

Are you suggesting it is not valid to try both?
User avatar
J'Kla
 
Posts: 900
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK

Korman 0.07 Released

Postby J'Kla » Thu Oct 18, 2018 12:02 am

Worth a try but it is low on my list of jobs.

I would rather find a solution to getting the plClient for dirtsand working on Windows10 first.

Actually plClient working on Wine on a Linux desktop would be even better :)
User avatar
J'Kla
 
Posts: 900
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK

Re: Korman 0.07 Released

Postby Deledrius » Thu Oct 18, 2018 1:18 am

J'Kla wrote:Worth a try but it is low on my list of jobs.

I know how that is.

J'Kla wrote:I would rather find a solution to getting the plClient for dirtsand working on Windows10 first.

I use Uru in Windows 10 without any issues. I suspect it may be a system configuration issue for you. Have you tried running the Gehn installer on that system to make sure the proper necessary prerequisite libraries are installed?

J'Kla wrote:Actually plClient working on Wine on a Linux desktop would be even better :)

You could give one of Korovev's PlayOnLinux scripts a try.
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1197
Joined: Mon Oct 01, 2007 1:21 pm

Re: Korman 0.07 Released

Postby J'Kla » Fri Oct 19, 2018 1:23 am

Deledrius wrote:
J'Kla wrote:I would rather find a solution to getting the plClient for dirtsand working on Windows10 first.

I use Uru in Windows 10 without any issues. I suspect it may be a system configuration issue for you. Have you tried running the Gehn installer on that system to make sure the proper necessary prerequisite libraries are installed?


Its something that has me puzzled in that it worked until Windows 10 did updates as a result I have no idea what changed so I have no reason to suspect that the problem lies in Windows10 rather than something missing from my client end.
I am sure I had Gehn running on this PC under Windows10 but it was not reinstalled aftr my rebuild so I am going to try that again.

I will then return to this post.

[edit]
OK I installed Gehn and ran Gehn and let it install all it wanted to do.

Then I copied everything from the root of the local Gehn install except server.ini to the local install of my offline install and then fired up the Link and it works.

There is some experimentation but needless to say its working.

When it starts I now get the Guild of Writers Splash screen (The Pen Nib). But I am happy this now works.
[/edit]
User avatar
J'Kla
 
Posts: 900
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK

Re: Windows 10 and plClient.exe issues

Postby Deledrius » Mon Oct 22, 2018 2:10 pm

I'm glad my deduction worked to solve your problem with the client. There's a reason we distribute those installers, and one is because a fresh system won't have the necessary libraries! Windows 10's major updates are essentially a complete re-install that (supposedly) retains your user data, so you may need to compensate from time-to-time for Microsoft's overzealousness.

The loading screen image is stored in the resource.dat file. You can use the one from MO:ULa if you prefer it, or even customize it yourself if you'd like! It's just a series of still images.
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1197
Joined: Mon Oct 01, 2007 1:21 pm

Re: Windows 10 and plClient.exe issues

Postby J'Kla » Tue Oct 23, 2018 3:43 am

I like using the Nib but what tools do I use to access and edit resource.dat?

I suppose this should go in tutorial requests. ;)

CONSIDER the question moved I have resubmitted it under tutorial requests. ;)
User avatar
J'Kla
 
Posts: 900
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK


Return to Plasma Development

Who is online

Users browsing this forum: No registered users and 1 guest

cron