Dirtsand on a VPS

Announcements and discussion regarding any projects related to Cyan Worlds' Plasma Engine including (but not limited to) CyanWorlds.com Engine, Drizzle, OfflineKI, PyPRP, and libHSPlasma.

Re: Dirtsand on a VPS

Postby Surta » Sat May 30, 2020 12:32 pm

Ok, apologies for the triple post, I'm excited :lol:

In the past, all I ever did was copy across "some" files into the moul-utils folder, and I was able to run manifest.py. I seem to remember it was the easiest step of all. Obviously I'm missing which files they were, or something else has changed. So now, following the chain of errors, this is how far I got.

From https://github.com/zrax/string_theory/w ... ing_theory

1.jpg
1.jpg (20.75 KiB) Viewed 534 times


I am pretty sure I didn't get any errors here, so I assume it's properly installed.

Next, https://github.com/H-uru/libhsplasma

Here I followed these instructions:

$ mkdir build
$ cd ./build
$ cmake ..


And here is where it goes wrong, because I'm still getting

CMake Error at CMakeLists.txt:51 (find_package):
By not providing "Findstring_theory.cmake" in CMAKE_MODULE_PATH this
project has asked CMake to find a package configuration file provided by
"string_theory", but CMake did not find one.

Could not find a package configuration file provided by "string_theory"
(requested version 2.0) with any of the following names:

string_theoryConfig.cmake
string_theory-config.cmake

Add the installation prefix of "string_theory" to CMAKE_PREFIX_PATH or set
"string_theory_DIR" to a directory containing one of the above files. If
"string_theory" provides a separate development package or SDK, be sure it
has been installed.


But it IS installed, so here's where I'm stuck I'm afraid... I just don't know what to do next. And when I try to run Manifest, it tells me:

from PyHSPlasma import *
ImportError: No module named PyHSPlasma
Surta
 
Posts: 74
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Tsar Hoikas » Sat May 30, 2020 2:53 pm

Surta wrote:Guys, Hoikas in particular - YOU DID IT!!!! It worked!!! I have a working server... with KI dispenser, closet works now and I have been in the desert. You have no idea how happy I am right now!!!!

Of course I got there the "cheating" way, by just using 7zip to create a python.pak.gz file and upload that to the ClientPreload folder. Now it downloads several times per session - but that is a small matter :D

Another small error, I visited the closet and got

[SDL] Requested invalid descriptor AvatarCustomization


But my guess is that once I manage to get the manifest script to work, I can start hunting for a better set of SDL files. I just can't believe I accidentally deleted the folder and lost my ability to use the script, it doesn't make sense...

I am SO excited right now, it was such a tremendous learning curve - still is - but I really think we're finally truly almost there!

/happydance


Congrats! If you want to cheaply fix the redownloading issue, you can edit the manifests directly. You'll want to get the md5 hash of python.pak and python.pak.gz and edit the lines containing it. Those should be found in SecurePreloader.mfs, ThinExternal.mfs, External.mfs, ThinInternal.mfs, and Internal.mfs. The line format is:
Code: Select all
client_filename.ext,server_filename.ext.gz,decompressed_hash,compressed_hash,decompressed_size,compressed_size,flags


The AvatarCustomization issue is a false-positive--there is no SDL file for that Age.

Surta wrote:Next, https://github.com/H-uru/libhsplasma

Here I followed these instructions:

$ mkdir build
$ cd ./build
$ cmake ..


I think it will be easier if we make cmake use the libraries Plasma's prepare_env.bat downloaded for us. I think this should look something like:
Code: Select all
cmake -DCMAKE_PREFIX_PATH=C:\path\to\plasma\build\devlibs -DCMAKE_INSTALL_PREFIX=<some path to install libHSPlasma to> -DENABLE_PYTHON=ON ..
cmake --build . --config Release
cmake --build . --config Release --target INSTALL
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 2028
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Dirtsand on a VPS

Postby Surta » Sat May 30, 2020 4:26 pm

Tsar Hoikas wrote:I think it will be easier if we make cmake use the libraries Plasma's prepare_env.bat downloaded for us. I think this should look something like:
Code: Select all
cmake -DCMAKE_PREFIX_PATH=C:\path\to\plasma\build\devlibs -DCMAKE_INSTALL_PREFIX=<some path to install libHSPlasma to> -DENABLE_PYTHON=ON ..
cmake --build . --config Release
cmake --build . --config Release --target INSTALL


Yesss!!! That finally worked! I chose moul-utils\libHSPlasma as the <some path to install libHSPlasma to> and it sure created the 4 folders bin, include, etc.

I reran the manifest.py script and it still tells me

Traceback (most recent call last):
File "C:\Users\user\Documents\GitHub\moul-utils\manifest.py", line 23, in <module>
from PyHSPlasma import *
ImportError: No module named PyHSPlasma


but I assume I need to tell the file to look in moul-utils\libHSPlasma? How would I do that?

If need be I'll try the "cheaply fix" - but naturally I prefer to get the script working again :D
Surta
 
Posts: 74
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Tsar Hoikas » Sat May 30, 2020 4:50 pm

Drop the libHSPlasma.dll and PyHSPlasma.pyd files into the "Lib\site-packages" directory of your python install... For me, that's C:\Python38\Lib\site-packages.
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 2028
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Dirtsand on a VPS

Postby Surta » Sat May 30, 2020 6:16 pm

Thanks, first of all, I found out I had Python 2.7 installed... I just installed Python v3.8 (latest). I couldn't find a libHSPlasma.dll file anywhere in any of the Githubs, but I copied PyHSPlasma.pyd to the folder you described. Now I'm getting another error... which, as always, I see as progress :lol:

File "manifest.py", line 31
default="D:\URU\FileSrv")
^
SyntaxError: (unicode error) 'unicodeescape' codec can't decode bytes in position 2-3: truncated \UXXXXXXXX escape
Surta
 
Posts: 74
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Sirius » Sun May 31, 2020 2:05 am

(Just passing by, but that sounds like something I can help with)

Surta wrote:SyntaxError: (unicode error) 'unicodeescape' codec can't decode bytes in position 2-3: truncated \UXXXXXXXX escape

That's because of the backwards slash "\". This is an "escape" character, which when combined with another letter, is interpreted as a special (usually non-printable) character. In that case, \U means "interpret the next characters as the ID of a unicode character". There are others, like "\n" (line break), "\t" (tabulation), ' \" ' (double quote, which does NOT terminate the string), etc.

So how do you input the regular backslash character ? Simple: you double it. So your path should be:
Code: Select all
D:\\URU\\FileSrv
User avatar
Sirius
 
Posts: 1300
Joined: Mon Jul 26, 2010 4:46 am
Location: France

Re: Dirtsand on a VPS

Postby Surta » Sun May 31, 2020 8:13 am

Thank you Sirius!!! That seemed to work because now I'm getting the NEXT error (yeah, better than a soap opera!)...

Traceback (most recent call last):
File "manifest.py", line 23, in <module>
from PyHSPlasma import *
ImportError: DLL load failed while importing PyHSPlasma: The specified module could not be found.


I guess I do need that libHSPlasma.dll after all but... somehow... I don't have it... (yes I looked in hidden folders too across my entire C drive).

---

Side note:

Oooohhh!!! I just now found out what files I copied into the moul-utils folder that made it work so smoothly before! When I just started toying with this, I found this site: https://code.google.com/archive/p/libhs ... ads?page=1 and copied the content of the Plasma_r932.zip into the moul-utils folder. That works only with Python 2.7 (I am actually converting now from a test folder). I thought I was going mad :lol: Of course at the time I was doing 300 things at once and never even wrote that down.

Still, if you don't mind, Hoikas, I would like to get manifest working with the newer Python and the proper tools/files... but at least for now I seem to have a working manifest again!
Surta
 
Posts: 74
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Tsar Hoikas » Mon Jun 01, 2020 6:24 am

Sorry, I misremembered the file name--it's HSPlasma.dll. You'll need both it and PyHSPlasma.pyd for it to work. Also, since you updated to Python 3.8, you will have to recompile libHSPlasma. Hopefully cmake will pick up on the update-it's always really fiddly with Python.
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 2028
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Dirtsand on a VPS

Postby Surta » Mon Jun 01, 2020 10:41 am

Thanks! I tried it but as you predicted, it hollered about v2.7. Uninstalled all versions of Python prior to 3.8 and also re-cloned the repository - that seemed to do it so it's recompiling as we speak. Unless I mention it again, consider that one solved :D - Edit: quick follow up on this. After recompiling and copying those two files to the Python installation folder, I still got the error of a missing DLL. Just trying something I copied those two files to the root of the moul-utils folder and now it's working (creating the manifest as we speak)! Yay!

I am however running into additional issues (who would have EVER thought that would happen, bwohaha).

The first issue is the Nexus is missing most of the public links except one unknown (fan?) age:

relto.jpg
relto.jpg (39.58 KiB) Viewed 448 times


Any idea how I can get the city locations back?

I have a larger issue of the server only working on one computer (the same problem we discussed on page 3 of this long, long thread and which we sort of dropped to get the rest going properly), but let's tackle this one problem at the time, haha!
Surta
 
Posts: 74
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Tsar Hoikas » Wed Jun 03, 2020 12:52 pm

I can't remember--were you using the SDL files from Gehn or from the H'uru repository? I suspect that nxusBookMachine.py is exploding because it's looking for something in the Gehn SDL files and can't find it. You may find more information about the issue by looking in the python.0.log in %LOCALAPPDATA%\Uru Live\log
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 2028
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

PreviousNext

Return to Plasma Development

Who is online

Users browsing this forum: No registered users and 1 guest