Page 3 of 15

Re: Dirtsand on a VPS

PostPosted: Mon Apr 08, 2019 11:56 am
by Tsar Hoikas
Surta wrote:- Uploaded the original URU folders (avi, dat, Python, SDL and sfx) to /opt/dirtsand/data as well.

- Created three files in /opt/dirtsand/authdata: AGES_ages.list, Python_pak.list and SDL_sdl.list. In those I pasted the file names and sizes, for example:

If you're using the script, you should not need to use the authdata lists or upload the actual game client. The script generates the manifests and the game archives for you (in the GameData, GameAudio directories).

The crash you're experiencing and the issue with Gahreesen seem to be linked to me. I know Gahreesen does a lot of funny business with its loading via Python scripts. Is your client using a Python.pak file in the Python directory?

Re: Dirtsand on a VPS

PostPosted: Mon Apr 08, 2019 12:03 pm
by Surta
Ahh I guess I did too much. Should I delete the three files in authdata? After all the work I've done on them? Jk :lol:

If I understand you correctly, I should also delete the two Client folders from the server, and the original content, right? (wait I see what you mean now, just the original client content) That'll save some space :)

As for the Python file, I copied the one from the Gehn shard (sorry). Funny enough that one downloaded correctly from my server.

I have deleted the superfluous files, restarted the server and reinstalled the client. When it finishes its initial download (about 72MB), it tries to start the game and then immediately crashes with the message:

URU had experienced a serious error and needs to close.
Loading Global...
Msg 11135

Do you think it's the Python.pak file?

Oh and I forgot to mention, it still doesn't download any of the extra client files and the avi folder.

Re: Dirtsand on a VPS

PostPosted: Mon Apr 08, 2019 3:17 pm
by Tsar Hoikas
It *could* be a problem with the Python.pak file. I would have thought the one from the Gehn Shard would work. We might need to investigate the client log files found in `%LOCALAPPDATA%/Uru Live`. I am wondering if the data server manifests are missing some files completely--specifically the Python.pak. IIRC this would prevent the python code from being loaded by the game.

Re: Dirtsand on a VPS

PostPosted: Mon Apr 08, 2019 3:40 pm
by Surta
Sure! I cleaned out the logs and then started the game, so you have a clean slate. Hope you see something here :)

Update: I think it's the Destiny client that was the culprit. I replaced it with Gehn's client (UruExplorer.exe and UruLauncher.exe instead of plClient.exe) and now it's downloaded all the missing bits and pieces... including the avi folder and client files that were not being downloaded.

Is it okay if I replace the current client with the Gehn one? I don't know yet how to compile that myself and the shard will not be public anyway.

Edit: ok, I recreated and uploaded the manifest files with the Gehn client files. With that it downloads everything but I can't login... getting this message on the server now:

Show Spoiler

Still... progress... I guess! :D

Re: Dirtsand on a VPS

PostPosted: Thu Apr 11, 2019 9:34 am
by Surta
After some more testing:

- Starting the game with plClient (Destiny version) and a full dataset (and using the shortcut -LocalData) will boot the game, but with many bugs. For example, although the desert and Teledahn are playable, many sounds are missing. Gahreesen is really broken to the point of being unplayable (due to the second floor MIA).

- Starting the game with plClient without -LocalData will result in downloading some files, but not all files needed so the client will crash when it tries to start the game.

- Starting the game with UruLauncher (Gehn version) will download the missing files, but then the client will hang at "logging in" and the server will say "[Auth] Wrong Build ID from 26". A second attempt will usually give another set of errors, sometimes crash the server altogether.

- Starting the game with plClient AFTER all the needed files are downloaded by UruLauncher will boot the game correctly. Sounds are working and Gahreesen is no longer broken either.

Although getting the game to work correctly is sort of semi doable by sequencing UruLauncher and plClient, I'm really hoping you guys know how to get UruLauncher to work correctly so that I can avoid all these unnecessary steps :D

Oh and another question (sorry!!): how do I enable Great Zero? There is no book in the Hood :oops:

Re: Dirtsand on a VPS

PostPosted: Fri Apr 12, 2019 5:43 pm
by Tsar Hoikas
The key here is going to be getting a complete dataserver working... As you've noted, yours is missing some files. Have you tried running the script against the the client that you have working now and using the results from that on the server?

To get the GZ to work, this command in the server console should fix things: `globalsdl Neighborhood nb01LinkBookGZVis 1`

Re: Dirtsand on a VPS

PostPosted: Fri Apr 12, 2019 6:37 pm
by Surta
Tsar Hoikas wrote:To get the GZ to work, this command in the server console should fix things: `globalsdl Neighborhood nb01LinkBookGZVis 1`

Whooo hoooo, you are brilliant!!! That worked! Thank you so much! :lol:

As for the missing files, I'm honestly at a loss what it could be. The game works fine on my main machine, but only with the Destiny Client. The Gehn client keeps refusing to go past the login screen while the server says it has the wrong build ID.
But only the Gehn client downloads the files that are necessary to start the game.

I tested it both with importing all files from the Uru Live installation and also downloading everything from my own server. Both methods result in exactly the same outcome - so I don't think there is anything wrong with the files. To answer your question more specifically: yes, I used the script on the folder that worked perfectly fine in local mode.

It's just a bit of a pain to switch from Gehn client to update files (which is not all that often, of course) to Destiny client to play the game, but it's not a dealbreaker either. I feel like we're so close to the solution! Once again I really appreciate your help. :)

Re: Dirtsand on a VPS

PostPosted: Sat Apr 13, 2019 12:34 pm
by Surta
If it helps, here are two more log files from two computers. Both are using the full dataset, both using the Destiny client after the Gehn client has finished its initial importing/downloading.

PC1 is the one that loads sounds perfectly and doesn't crash... not even after a fresh installation.
(55.55 KiB) Downloaded 105 times

PC2 doesn't have any game sounds and crashes right before going into Relto. I created a new avi on that just to test and I can go through the whole closet routine, then it tries to load Relto and you see the loading messages flashing in the left bottom corner - then it crashes right before it should show the avatar in Relto. PC3 behaves in exactly the same way as PC2.
(47.52 KiB) Downloaded 102 times

To make absolutely sure there isn't anything wrong with the data, I ran the on the working installation on PC1 (after I removed the temp folder in ogg, for the sake of not leaving out any information) and replaced everything in the data folder on the VPS.

Unfortunately I can't provide any logs of the Gehn client, for the simple reason that it doesn't proceed to the point of creating any :lol:

Re: Dirtsand on a VPS

PostPosted: Sat Apr 13, 2019 1:03 pm
by Tsar Hoikas
These logs look better.

Given that the issue is with missing sounds, I looked at PC2's audio log and noticed that the audio device was never created. You might want to try running the OpenAL installer "oalinst.exe" on the computers that crash. That file *should* be included with the Gehn client.

Re: Dirtsand on a VPS

PostPosted: Sat Apr 13, 2019 1:19 pm
by Surta
Whaaa, no... that didn't work :cry: The game still crashes right at "Loading age... Personal. StartupHelpGUI" - and still no sound.

However, I have been trying more things. I noticed that on PC2, even if I load it with the line -LocalData, it will now crash where it wouldn't before. Luckily I had still kept the original folder that did work - and noticed a few files are different in Dirtsand than they are in Destiny:

- Nxcooking.dll
- OpenAL32.dll
- python27.dll
- resource.dat

I copied those over to the working folder, and now the game doesn't crash any longer. Still no sound, but some progress al the same :D

Now I'm in the process of running the manifest script again. Which reminds me, is there a way to just run the script on the files that have changed and upload those, or do I have to include the entire folder each time?

This is turning into a full time job - but it's gotten to the point where I just don't want to give up now :D