Dirtsand on a VPS

Announcements and discussion regarding any projects related to Cyan Worlds' Plasma Engine including (but not limited to) CyanWorlds.com Engine, Drizzle, OfflineKI, PyPRP, and libHSPlasma.

Re: Dirtsand on a VPS

Postby Surta » Thu May 07, 2020 11:33 am

Thanks! Whoo hoo, well, at least partially!

This is what I did: I found a devlibs folder in "build" (under Plasma). It already contained a folder devlibs... which contained a folder debug and libs. The debug folder already contained a folder libs as well. Ok that probably came across as gibberish, so I'll try to created a tree:

The folder ..\Plasma\build\. contains

.\devlibs\debug\lib
and
.\devlibs\lib

So I copied the content .\devlibs\lib to .\devlibs\debug\lib (overwriting a few existing files) and ran the batch again. Now I'm getting:

Show Spoiler


At least it finished the process now! After that I opened the Plasma.sln file in Visual Studio 17, changed debug to release and selected "Build Solution". That failed and this time I managed to grab the entire log - oh, I can't paste it in one message, so be prepared for LOOONG message next :D
Last edited by Surta on Thu May 07, 2020 11:38 am, edited 1 time in total.
Surta
 
Posts: 88
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Surta » Thu May 07, 2020 11:35 am

Entire Visual Studio log, part 1:

Show Spoiler
Surta
 
Posts: 88
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Surta » Thu May 07, 2020 11:35 am

Part 2:

Show Spoiler
Surta
 
Posts: 88
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Tsar Hoikas » Fri May 08, 2020 5:29 pm

Can you share the contents of the CMakeCache.txt file from the build folder?
Image
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 2111
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Dirtsand on a VPS

Postby Surta » Fri May 08, 2020 6:01 pm

Of course :) Here it is, in zip format... finally got smart and not post it all in a spoiler haha.
Attachments
CMakeCache.zip
(5.74 KiB) Downloaded 51 times
Surta
 
Posts: 88
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Tsar Hoikas » Fri May 08, 2020 7:58 pm

Hmm... It looks like CMake is not finding the CURL libraries at all for you. I just ran prepare_env.bat in a clean checkout of the repository and was able to build the client just fine. What version of CMake are you using?
Image
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 2111
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Dirtsand on a VPS

Postby Surta » Sat May 09, 2020 10:04 am

I'm using Cmake v3.17.1 on Windows 10.
Surta
 
Posts: 88
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Tsar Hoikas » Sun May 10, 2020 6:01 pm

It looks like there has been some kind of regression or change in behavior in CMake 3.17 that's causing all these problems. Try rolling back to CMake 3.16--I was able to build successfully using that. You may need to delete the build folder and rerun prepare_env.bat.

EDIT: It seems you can fix this issue by issuing this command on CMake 3.17 from the build directory: cmake -DCURL_NO_CURL_CMAKE=1 ../
Image
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 2111
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Dirtsand on a VPS

Postby Surta » Mon May 11, 2020 11:40 am

Progress... I think :D Here's the status so far:

- I deleted the Plasma\build folder (in fact just to be sure I re-cloned Plasma from scratch)
- Uninstalled Cmake and installed v3.16.6 instead.
- Then I ran the prepare_env.bat file.
- After that, I copied the content of build\devlibs\lib to build\devlibs\debug\lib.
- Opened the Plasma.sln file in Visual Studio, selected release and built the solution.

This time, I got no errors, "only" 70 warnings... and in the end it told me it skipped building. But I do think that is at least some progress, right? :lol:
I have attached the entire Visual Studio log and the CMakeCache file.
Attachments
build.zip
(15.64 KiB) Downloaded 48 times
Surta
 
Posts: 88
Joined: Fri Mar 29, 2019 1:13 pm

Re: Dirtsand on a VPS

Postby Tsar Hoikas » Mon May 11, 2020 6:58 pm

Looks like you now have a client built at C:\Users\user\Documents\GitHub\Plasma\build\bin\Release\plClient.exe ;)
Image
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 2111
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

PreviousNext

Return to Plasma Development

Who is online

Users browsing this forum: No registered users and 2 guests