Camera movement problems

Announcements and discussion regarding the Gehn CWE Shard.

Moderator: Gehn Shard

Camera movement problems

Postby Solomoncrunch » Sat Oct 17, 2020 12:32 am

I've noticed since Thursday 10/15 that my first and third person camera controls constantly rubber band - like very bad lag. In first person, if I attempt to use my mouse to turn my camera a certain distance in any direction my screen snaps back to the original position of the camera. In third person, I can see my character model rotate a few degrees and then snap back straight. This can happen tens of times in a second if I move the mouse fast enough. The bug doesn't affect any other kind of camera movement caused by turning left or right with the arrow keys, nor does any of my other movement rubber band. I have tried restarting and reinstalling, and even when I create a new avatar the bug persists. It is almost 100% persistent at all times and makes this shard unplayable. Up until Thursday everything was working fine, and I didn't change anything about my mouse, computer, installation, etc. The problem seemed to start about halfway through the session on Thursday when I tried to have my friend join my neighborhood, resulting in a bug that had us contacting tech support. That neighborhood bug has since been resolved, but the unusable camera is still there. I can't find any more information online so I'm really hoping it's some weird server problem. Any suggestions for troubleshooting?
Solomoncrunch
 
Posts: 6
Joined: Mon Oct 12, 2020 1:02 pm

Re: Camera movement problems

Postby Solomoncrunch » Sat Oct 17, 2020 3:43 pm

Upon further research, it appears this was an issue originally noted with the Win 10 1703 FCU build. Another forum post (viewtopic.php?f=9&t=6887) mentions it showed that a workaround had been added to the game that specifically flagged for specific builds of windows to change how the mouse behaved to fix this bug. This helped me to remember that on the fated Thursday I began seeing this bug, my windows did actually update to build 2004. Is there anything I can do to manually change these pointers or calls or something? I really can't rollback this machine...
Solomoncrunch
 
Posts: 6
Joined: Mon Oct 12, 2020 1:02 pm

Re: Camera movement problems

Postby Tsar Hoikas » Sat Oct 17, 2020 3:43 pm

Is this with the left or right mouse button? Also, what revision of Windows are you using? If on Windows 10, please include the update level (eg 1903). (Edit: I see this question has been answered)
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 2073
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Camera movement problems

Postby Solomoncrunch » Sat Oct 17, 2020 4:50 pm

I just double-checked and it affect both mouse buttons.
Solomoncrunch
 
Posts: 6
Joined: Mon Oct 12, 2020 1:02 pm

Re: Camera movement problems

Postby Tsar Hoikas » Fri Oct 23, 2020 2:33 pm

Odd. We had to go back and adjust the fix so that new versions of Windows beyond FCU would be fixed. I do know of some minor issues with holding down the RMB, but the LMB should be working as expected. :?
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 2073
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Camera movement problems

Postby Solomoncrunch » Sun Oct 25, 2020 11:19 pm

I recorded my screen to show the bug affecting both the left and right mouse buttons. Unfortunately I forgot to record in first person - let me know if that would be helpful in any way and I would be happy to record and upload that too. The clip can be found at https://youtu.be/RmpxzKtSxKo
Solomoncrunch
 
Posts: 6
Joined: Mon Oct 12, 2020 1:02 pm

Re: Camera movement problems

Postby Tsar Hoikas » Wed Oct 28, 2020 1:42 pm

Yeah, that looks just like the old, supposedly fixed mouse bug. Does this still happen in windowed mode?
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 2073
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Camera movement problems

Postby Solomoncrunch » Thu Oct 29, 2020 1:58 am

I have confirmed that I still have the bug with left and/or right mouse while windowed.
Solomoncrunch
 
Posts: 6
Joined: Mon Oct 12, 2020 1:02 pm

Re: Camera movement problems

Postby Solomoncrunch » Fri Oct 30, 2020 7:41 pm

Full uninstallation, restart, updated graphics driver, restart, reinstall Gehn shard under Documents instead of Program Files, restart.
It now works and the bug is no longer present with no further configuration. I don't understand why I was unable to fix it the first time I reinstalled but perhaps it had something to do with the specific Nvidia driver I was using at the time. I hope nobody else sees this problem.
Solomoncrunch
 
Posts: 6
Joined: Mon Oct 12, 2020 1:02 pm


Return to Gehn Shard

Who is online

Users browsing this forum: No registered users and 2 guests

cron