Installing Gehn Shard on OSX

Announcements and discussion regarding the Gehn CWE Shard.

Moderator: Gehn Shard

Re: Installing Gehn Shard on OSX

Postby Korovev » Tue Jan 26, 2016 4:15 am

Some small news, though I don’t know if they have any relevance: I managed to install the Visual C++ 2015 Redist on PlayOnLinux. It required emulating Windows 8.1 and installing dotnet45 (maybe it was obvious, but I didn’t know it), which in turn required setting ptrace_scope to 0.

The bad news are that it improved nothing on launching the Gehn shard, and I can’t replicate the ‘trick’ on MacOS because apparently there is no /proc/sys/kernel/yama/ptrace_scope.

Edit: well, I did manage to install dotnet45 and vcrun2015 (by selecting just those on a new wrapper), but the outcome is the same.
Gehn #137074, Deep Island #194197. Gahreesenomee biv keneet pishoeet b’set!
Want to know what’s going on in the Cavern? Get tweets from the GoMe.

MacOS wrappers, PlayOnLinux/Mac scripts, DniTools, goodies.
User avatar
Korovev
 
Posts: 167
Joined: Sun Jan 27, 2013 5:18 am

Re: Installing Gehn Shard on OSX

Postby Deledrius » Tue Feb 23, 2016 5:59 pm

Deledrius wrote:Semi-good news: Although updating my existing Wineskin produced the same errors as before, creating a new one (Wrapper v2.6.2, Wine Engine v1.8-rc3) allowed me to successfully start the launcher and open the game... which then crashes. The main hurdle might be over; if someone more experienced with this can figure out what's missing it might be worth a try again.


Great news!

Using Wineskin Wrapper v2.6.2 and Wine Engine v1.9.2, I was able to log into Gehn and play! Wine has finally fixed up their incomplete implementation and we can play on OSX once again. :D :D

It seemed to be a bit unhappy initially about running in windowed mode, but fullscreen mode works fine (and windowed is behaving now, too). Hopefully the remaining problems will continue to be fixed as Wine's support improves.
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1298
Joined: Mon Oct 01, 2007 1:21 pm

Re: Installing Gehn Shard on OSX

Postby Korovev » Wed Feb 24, 2016 1:12 pm

I am stuck at “Loading Global...”, though without error messages, so maybe it’s just taking a long time. Still an improvement :)

Edit: nevermind, I’m in! Though I had to copy the dat folder from the Windows side.
Gehn #137074, Deep Island #194197. Gahreesenomee biv keneet pishoeet b’set!
Want to know what’s going on in the Cavern? Get tweets from the GoMe.

MacOS wrappers, PlayOnLinux/Mac scripts, DniTools, goodies.
User avatar
Korovev
 
Posts: 167
Joined: Sun Jan 27, 2013 5:18 am

Re: Installing Gehn Shard on OSX

Postby Korovev » Thu Feb 25, 2016 4:34 pm

By the way: bug 39437.

Edit: and here’s a wrapper.
Gehn #137074, Deep Island #194197. Gahreesenomee biv keneet pishoeet b’set!
Want to know what’s going on in the Cavern? Get tweets from the GoMe.

MacOS wrappers, PlayOnLinux/Mac scripts, DniTools, goodies.
User avatar
Korovev
 
Posts: 167
Joined: Sun Jan 27, 2013 5:18 am

Re: Installing Gehn Shard on OSX

Postby boblishman » Fri Feb 26, 2016 11:30 am

WOW! This is great news ... but I'm still a little confused (to say the least!):

1) Has Wineskin been "fixed" to correct the problem we are having (and if so, what to I need to do to update/build my own wrapper) - or have you done some personal "magic" to your wrapper to get it working ?

2) When you say "here is the wrapper" - at 1/2 gig thats a huge wrapper!
I have always built my own wrappers in the past so have no idea how to use yours. Could you enlighten me please?

Meanwhile ... KUDOS for getting in to Ghen.

Bob
when it comes to Age creation ... "DOH" seems to be my middle name...
User avatar
boblishman
 
Posts: 837
Joined: Fri Oct 05, 2007 4:47 pm
Location: Spain

Re: Installing Gehn Shard on OSX

Postby Christian Walther » Fri Feb 26, 2016 2:57 pm

Thanks Korovev! Interestingly enough, I get much farther with this wrapper than with one I made myself – mine would fail to start pretty much anything with err:module:load_builtin_dll failed to load .so lib for builtin L"msxml3.dll": dlopen(/Users/cwalther/Applications/Wineskin/Gehn Shard.app/Contents/Frameworks/wswine.bundle/bin/../lib/wine/msxml3.dll.so, 258): Library not loaded: @executable_path/../Frameworks/libxml2.2.dylib (and putting that there wouldn’t help). Now with yours I can update and log in, but it crashes at the initial Updating screen. I’ll see if I can get anything useful out of the crash dump.

Bob, here’s how to use it:
  1. If you have an existing Gehn or MOULa install: Right-click on the Gehn Shard application and choose Show package contents, navigate to drive_c/Program Files/Gehn Shard/ and copy the avi, dat, and sfx folders from the existing installation there.
  2. Right-click on the Gehn Shard application and choose Show package contents and open the Wineskin application there.
  3. Click Advanced.
  4. Paste this into the EXE Flags field:
    Code: Select all
    /ServerIni=repair.ini /Repair
  5. Click Test Run. This should start the updater and have it download any missing files from MOULa.
  6. Once you’re at the login screen, quit.
  7. Empty the EXE Flags field again and close the Wineskin Advanced window.
  8. Double-click the Gehn Shard application.
Christian Walther
 
Posts: 438
Joined: Sun Jun 08, 2008 3:10 am
Location: Switzerland

Re: Installing Gehn Shard on OSX

Postby Korovev » Fri Feb 26, 2016 5:20 pm

There’s something more: in one of the comments in the bug report I’ve posted there’s a link to a zip file, with a few missing DLLs and a Registry file (point 2 in the instructions is simply: expand the zip file and overwrite the files in the system32 folder). That apparently also fixed the status message!

If you start with a new wrapper, you need to update Winetricks and install vcrun2015; Winetricks will install the rest along the way (it will take a while!). I used the Gehn installer, then copied over the usual dat and sfx folders. Maybe that prepares the environment better then running repair.ini? I haven’t tried that yet.

With this wrapper I can log in, however it takes ~15 minutes to get to the avatar selection and 15 more to get to Relto. I don’t think it’s my connection, because on Windows the login is almost immediate. I tried the same procedure with PlayOnMac, but with no success.
Gehn #137074, Deep Island #194197. Gahreesenomee biv keneet pishoeet b’set!
Want to know what’s going on in the Cavern? Get tweets from the GoMe.

MacOS wrappers, PlayOnLinux/Mac scripts, DniTools, goodies.
User avatar
Korovev
 
Posts: 167
Joined: Sun Jan 27, 2013 5:18 am

Re: Installing Gehn Shard on OSX

Postby boblishman » Sat Feb 27, 2016 8:23 am

Christian Walther wrote:I can update and log in, but it crashes at the initial Updating screen. I’ll see if I can get anything useful out of the crash dump.

Mine did that the first few times ... it was downloading a prp file (Global District Screen settings or something).
After trying it a couple of times I now seem to be where Korovev is ..... currently waiting for the wrapper to start :?
when it comes to Age creation ... "DOH" seems to be my middle name...
User avatar
boblishman
 
Posts: 837
Joined: Fri Oct 05, 2007 4:47 pm
Location: Spain

Re: Installing Gehn Shard on OSX

Postby boblishman » Sat Feb 27, 2016 9:17 am

ok.... I have a load of "zero bytes" prp files in my dat folder that all start with "GUI_District_ -----" and it crashes when it tries to download them.

Image
when it comes to Age creation ... "DOH" seems to be my middle name...
User avatar
boblishman
 
Posts: 837
Joined: Fri Oct 05, 2007 4:47 pm
Location: Spain

Re: Installing Gehn Shard on OSX

Postby Deledrius » Sat Feb 27, 2016 9:18 am

Korovev wrote:With this wrapper I can log in, however it takes ~15 minutes to get to the avatar selection and 15 more to get to Relto. I don’t think it’s my connection, because on Windows the login is almost immediate. I tried the same procedure with PlayOnMac, but with no success.


boblishman wrote:After trying it a couple of times I now seem to be where Korovev is ..... currently waiting for the wrapper to start :?


That's what happened to me when running it in Windowed mode. Try switching to Fullscreen and see if that helps. It loaded instantly for me. I'm not sure why this is an issue (it used to be in reverse, and was connected to VSync).
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1298
Joined: Mon Oct 01, 2007 1:21 pm

PreviousNext

Return to Gehn Shard

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron