shard down, 31 December 2015

Announcements and discussion regarding the Gehn CWE Shard.

Moderator: Gehn Shard

shard down, 31 December 2015

Postby Acorn » Thu Dec 31, 2015 3:36 am

I'm afraid the shard seems to have crashed. :( I get to "connecting" but no further. I was playing it at the time, hope it was nothing I did! :roll:
Image
Acorn
 
Posts: 685
Joined: Sun Feb 26, 2012 9:56 am

Re: shard down, 31 December 2015

Postby Deledrius » Thu Dec 31, 2015 4:45 am

I've restarted it. What were you doing when you experienced the crash?
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1303
Joined: Mon Oct 01, 2007 1:21 pm

Re: shard down, 31 December 2015

Postby Acorn » Thu Dec 31, 2015 4:57 am

Thanks! I pm'ed Adam to explain (and gave a shorter account on the Haxman thread) - I was on the high balcony in my hood and then used my relto book. This took me to the black screen with the logo, and the logo changed colour as normal but I never got to relto. I eventually used task manager to shut down.
Image
Acorn
 
Posts: 685
Joined: Sun Feb 26, 2012 9:56 am

Re: shard down, 31 December 2015

Postby Tsar Hoikas » Fri Jan 01, 2016 10:35 pm

I've seen this crash a few times in the past week, and I just managed to catch it in the debugger. I'm not 100% sure what's going wrong, but I created a patch for what I think is wrong and have deployed it to the server. What I do know is that the crash is triggered by a certain situation when leaving an age. I still have the server running under the debugger and will be watching... If the shard stops responding, let me know! That means I've got something.

On the plus side, in looking for this crash, I discovered and fixed a problem in the server that could allow (skilled programmer) malicious users to crash it.
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 1925
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia


Return to Gehn Shard

Who is online

Users browsing this forum: No registered users and 2 guests