Creating Ages using an iMac

If you feel like you're up to the challenge of building your own Ages in Blender or 3ds Max, this is the place for you!

Creating Ages using an iMac

Postby boblishman » Mon Jul 24, 2017 4:31 am

Ive been out of the 'Age-building loop' for so long now and have no idea if it is possible to create Ages using ONLY an iMac (running the latest Sierra).
If anyone out there is building (not playing - I can do that just fine) Ages using a mac, I would appreciate a quick heads up as to what version of Blender/3DMax you are using plus how you set up your machine to export your creations.

I've spent about 3 weeks now trying to use Blender 2.49 (which is an nightmare to use as it flickers constantly) and I would like to be able to use something more stable and functional. Although the Pyprp (1.7) export module is there, when I export it says :

Code: Select all
Last login: Mon Jul 24 12:20:38 on console
Bobs-iMac:~ boblishman$ /Users/boblishman/Documents/blender-2.49b-OSX-10.5-py2.5-intel/blender.app/Contents/MacOS/blender\  ; exit;
Compiled with Python version 2.6.9.
Warning: could not set Blender.sys
Warning: could import or build sys.path
Checking for installed Python... No installed Python found.
Only built-in modules are available.  Some scripts may not run.
Continuing happily.
Warning: import of sys module failed
Warning: could not import python sys module. some modules may not import.
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/Users/boblishman/Documents/blender-2.49b-OSX-10.5-py2.5-intel/blender.app/Contents/MacOS/.blender/scripts/PyPRP/prp_Export.py", line 50, in <module>
    from PyPRP import prp_Config
ImportError: No module named PyPRP


Any help would be gratefully received.

Thanks

Bob
when it comes to Age creation ... "DOH" seems to be my middle name...
User avatar
boblishman
 
Posts: 837
Joined: Fri Oct 05, 2007 4:47 pm
Location: Spain

Re: Creating Ages using an iMac

Postby Deledrius » Fri Jul 28, 2017 1:56 pm

In theory it should be possible to use Korman in the most recent version of Blender on MacOS, but I've had some difficulty getting it to build just right against the necessary version of Python that Blender is built with. We hope to have a solution for that sooner rather than later (I'm hoping one of our Mac experts will be able to figure out what I've missed). Everything else is in place now for it to be usable on MacOS and be able to export for Uru:CC and MOULa.

That error you have doesn't look like it's a problem with PyPRP at all, but your Blender install is missing/can't find its Python library. What version of MacOS are you running on? Your Blender 2.49 looks like it was built for 10.5 and Py2.5. If your system is missing Py2.5 this could be the cause.
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1265
Joined: Mon Oct 01, 2007 1:21 pm

Re: Creating Ages using an iMac

Postby Christian Walther » Sat Jul 29, 2017 2:03 am

Wait, export for MOUL on MacOS? I thought that required a Windows-only PhysX? Did I miss anything?
Christian Walther
 
Posts: 436
Joined: Sun Jun 08, 2008 3:10 am
Location: Switzerland

Re: Creating Ages using an iMac

Postby Deledrius » Sat Jul 29, 2017 10:44 am

Christian Walther wrote:Wait, export for MOUL on MacOS? I thought that required a Windows-only PhysX? Did I miss anything?


Last December, and included in Korman 0.05: H-uru/Plasma#533 H-uru/libHSPlasma#82
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1265
Joined: Mon Oct 01, 2007 1:21 pm

Re: Creating Ages using an iMac

Postby Christian Walther » Sat Jul 29, 2017 1:24 pm

Ah yes, I had forgotten about that. Still, it’s not quite MOULa-compatible until we get that one on H-uru/Plasma.
Christian Walther
 
Posts: 436
Joined: Sun Jun 08, 2008 3:10 am
Location: Switzerland

Re: Creating Ages using an iMac

Postby Deledrius » Sat Jul 29, 2017 5:22 pm

Christian Walther wrote:Ah yes, I had forgotten about that. Still, it’s not quite MOULa-compatible until we get that one on H-uru/Plasma.

Yes, well, it's the closest any of us can do. ;) Fortunately it's a small commit and easy to assess. Anyway, I was using the term to refer to the engine, not the specific server.

I'm not sure which bet would be the losing one: Age Builders upgrading to modern Blender first, or Cyan being ready for Fan Ages. Either one is likely still some time away.
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1265
Joined: Mon Oct 01, 2007 1:21 pm

Re: Creating Ages using an iMac

Postby boblishman » Mon Jul 31, 2017 11:23 am

Deledrius wrote:Your Blender 2.49 looks like it was built for 10.5 and Py2.5. If your system is missing Py2.5 this could be the cause.


Yes, since I have upgraded my system to Sierra, the Py2.5 was removed during the upgrade and I can not find a way to put it back (due to SIP.)
There is an alias folder called 2.5 in the python library that points to the Py2.7 that is now part of MacOSX. I would appreciate any instructions that could make my 2.49 Blender find the Py2.5 that I have downloaded and unzipped.

(This SIP thing is driving me crazy. I hate not having full control of my own machine but also fear the consequences of disabling it and screwing up my OS. :x )
when it comes to Age creation ... "DOH" seems to be my middle name...
User avatar
boblishman
 
Posts: 837
Joined: Fri Oct 05, 2007 4:47 pm
Location: Spain

Re: Creating Ages using an iMac

Postby Deledrius » Tue Aug 01, 2017 12:26 am

I'll see what I can find for you. :)

Edit: From the looks of this post there isn't much you can do about the problem while SIP is enabled. However, it would seem that you can selectively disable SIP in places where you don't need its heavy-handed kid gloves. I haven't tried this though, and I understand your reluctance to mess with this.

Another possible option that doesn't require messing with SIP at all is to install Python 2.5 in a user location, and then modifying the PYTHONPATH environment variable so that Blender 2.49 finds it. At least, I think this might work...
Last edited by Deledrius on Tue Aug 01, 2017 11:18 pm, edited 1 time in total.
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1265
Joined: Mon Oct 01, 2007 1:21 pm

Re: Creating Ages using an iMac

Postby boblishman » Tue Aug 01, 2017 10:51 pm

Deledrius wrote:I'll see what I can find for you. :)

Thank you. I'd prefer to continue using Blender 2.49 with Py2.5 but if that's not possible, then the latest Blender and plugin.
(Currently the wiki has no instructions for Mac installation of Korman)
https://guildofwriters.org/wiki/Korman:Installation#Mac
when it comes to Age creation ... "DOH" seems to be my middle name...
User avatar
boblishman
 
Posts: 837
Joined: Fri Oct 05, 2007 4:47 pm
Location: Spain

Re: Creating Ages using an iMac

Postby Deledrius » Tue Aug 01, 2017 11:21 pm

Heh, I edited my post to add more information... and you replied right under while I was writing it. :lol:

As I said above, Korman on OSX should be possible but isn't officially supported yet. We need some help from a Mac person getting that done. I've tried several things to get it working and I'm not sure yet why it won't load. It should just work.
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1265
Joined: Mon Oct 01, 2007 1:21 pm

Next

Return to Building

Who is online

Users browsing this forum: No registered users and 3 guests