forum website intermittently "not secure"

Anything that isn't directly related to Age Creation but that might be interesting to Age developers.

forum website intermittently "not secure"

Postby Acorn » Sat Apr 08, 2017 3:23 am

Hi, for the past three days, when I have visited the forum in the morning UK time I get stopped by a message telling me this website is not secure and my connectin is not private. But visiting in the evening, UK time, each time it's been fine and I've had no error messages. I'm a bit puzzled by the intermittency! :o
Image
Acorn
 
Posts: 649
Joined: Sun Feb 26, 2012 9:56 am

Re: forum website intermittently "not secure"

Postby Deledrius » Sat Apr 08, 2017 7:11 pm

There are some users who post images from places like Photobucket, sometimes even in their signatures, and aren't using HTTPS for the resource. That can cause mixed content warnings from your browser. It's unfortunate, but currently unavoidable for places like this forum in which people can post things from random other sites.
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 967
Joined: Mon Oct 01, 2007 1:21 pm

Re: forum website intermittently "not secure"

Postby Acorn » Sun Apr 09, 2017 9:21 am

Thanks, Deledrius. As far as I can tell, the intermittent "not secure" message flips on or off even when there have been no new posts to these forums. So it's quite a puzzle as to what is triggering the change. Again, today, I had the message this morning, but by 5pm UK time it's apparently ok again.
Image
Acorn
 
Posts: 649
Joined: Sun Feb 26, 2012 9:56 am

Re: forum website intermittently "not secure"

Postby Deledrius » Tue Apr 11, 2017 3:10 pm

Another potential source of that message is that some SSL certs are provided by CAs in which browsers are removing their trust. A page with content served across such a connection might produce that error as well.
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 967
Joined: Mon Oct 01, 2007 1:21 pm

Re: forum website intermittently "not secure"

Postby Tsar Hoikas » Thu Apr 13, 2017 8:39 pm

I've been planning to post about the issue Deledrius raises above but have been really busy...

We got our SSL certificate back before StartCom was bought out by WoSign. They were a legit, trustworthy entity when we got ours. Unfortunately, once WoSign bought them out, the combined company started doing some questionable things that makes all of StartCom's certificates look shady. I know Google Chrome on my phone does not like the certificate any more. I don't know about the desktop version of Chrome. Firefox is still happy. I quite frankly don't care if Internet Explorer works. Your mileage may vary. I assure you that no matter how many red flags are thrown up, the GoW website is safe, however.

In the coming weeks, I will devote some time to acquiring a new certificate. Probably next weekend. I will likely be using Let's Encrypt... which has its own issues, but I don't think they will cause browsers to revoke their trust.
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 1781
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: forum website intermittently "not secure"

Postby Acorn » Fri Apr 14, 2017 3:43 pm

Thanks, Adam and Deledrius, for the explanation and reassurance. I have been encountering the issue when using Chrome on my laptop. Great to know that Firefox still treats the website appropriately, I'll swap to that for the time being.
Image
Acorn
 
Posts: 649
Joined: Sun Feb 26, 2012 9:56 am

Re: forum website intermittently "not secure"

Postby Charura » Fri Apr 14, 2017 6:58 pm

Tsar Hoikes wrote: I quite frankly don't care if Internet Explorer works


ROFLOL
Gehn Shard avvies: charura 10827 chickopee 142711 cannon belle 144577 char gearz 149794 teri dactyl 153077
Moul(a) Charura 55400 Chickopee 20089892 Cannon Belle 13686512 Char Gearz 706359 Teri Dactyl 12658065
Charura
 
Posts: 178
Joined: Wed Oct 14, 2009 9:26 am

Re: forum website intermittently "not secure"

Postby Tsar Hoikas » Sat Apr 22, 2017 4:05 pm

This issue should now be fixed.
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 1781
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: forum website intermittently "not secure"

Postby Acorn » Sun Apr 23, 2017 4:30 am

Yay! Thank you :D
Image
Acorn
 
Posts: 649
Joined: Sun Feb 26, 2012 9:56 am


Return to Off-Topic Discussion

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron