Invalid Manifest

If you feel like you're up to the challenge of building your own Ages in Blender or 3ds Max, this is the place for you!

Invalid Manifest

Postby Zorkmid » Fri Oct 19, 2018 7:59 am

When my client starts up the server displays the following error messages:
requested invalid manifest /opt/dirtsand/data/SecurePreloader.mfs
requested invalid manifest /opt/dirtsand/data/CustomAvatars.mfs

I guess that I need to generate manifest files to be served to the client from my data directory and these are missing? The installation instructions point me to a python 2.7 script [GUM] that generates manifest files, but the instructions are a bit vague. In particular, the script talks about a DROID key to use for SecurePreloader lists. Is the DROID key something that we generate?

How do manifest files work? What are they used for? Does GUM create a text file that lists all the files needed by the client so that the client knows what needs to be added to his local installation?
I'm confused.

Thanks.
Zorkmid
 
Posts: 11
Joined: Fri May 11, 2012 8:51 am

Re: Invalid Manifest

Postby Deledrius » Mon Oct 22, 2018 2:20 pm

By default, the client patcher requests the manifest to know which files it needs to download. However, you don't need to generate the manifests or use the patcher for a local testing server, as long as you have a fully-complete set of data files (i.e., the dat, Python, and avi folders) on your client. If you launch the plClient executable with the -LocalData flag, it will assume it has everything it needs and allow you to proceed.

If you intend to open this server up to other players, that's a different matter, and you'll probably want to generate proper manifests in order to distribute your additions (be sure to not distribute Cyan's files, however). This is only necessary for a server with custom content, however.


Zorkmid wrote:In particular, the script talks about a DROID key to use for SecurePreloader lists. Is the DROID key something that we generate?


The "droid" key is the encryption key generated when you created your server.ini. It's listed as Key.Droid in that configuration file.
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1197
Joined: Mon Oct 01, 2007 1:21 pm

Re: Invalid Manifest

Postby Zorkmid » Tue Oct 23, 2018 6:44 am

Thanks.
If I add -LocalData to the command line it avoids the invalid manifest errors. Now the screen progresses to 'Loading Global' and shows a counter of the number of messages processed. That count is currently greater than a million and shows no sign of finishing. Is that to be expected? Or have I hit another error condition?
Zorkmid
 
Posts: 11
Joined: Fri May 11, 2012 8:51 am

Re: Invalid Manifest

Postby Deledrius » Tue Oct 23, 2018 4:27 pm

Zorkmid wrote:Thanks.
If I add -LocalData to the command line it avoids the invalid manifest errors. Now the screen progresses to 'Loading Global' and shows a counter of the number of messages processed. That count is currently greater than a million and shows no sign of finishing. Is that to be expected? Or have I hit another error condition?


That sounds like you're missing some data files, and the client is waiting for them. Make sure you have your localdata client set up with the latest data from the SDL, Age/Fni, and Python files available from our moul-scripts repository, as well as all of the PRP/LOC/etc. files from a fully-working installation (Gehn or MOULa should do, just copy the moul-scripts files over them in your new client).
User avatar
Deledrius
Gehn Shard Admin
 
Posts: 1197
Joined: Mon Oct 01, 2007 1:21 pm

Re: Invalid Manifest

Postby Zorkmid » Thu Oct 25, 2018 8:26 pm

That helped a lot. Thank you very much.
Just to be clear, I loaded the \dat directory with age and fni files from the moul-scripts repository and took the csv, loc, prp and p2f files from a running MOULA instance. I loaded the \SDL directory with files from the moul-scripts repository. I loaded the \sfx and \sfx\streaming directories with ogg and wav files from a running MOULA instance.

It started to link, but I received a 'LinkToAge failed' message. If I check the server I notice a number of errors such as:
[SDL] Requested invalid descriptor AvatarCustomization
[Vault] Warning: Could not find SDL descriptor for AvatarCustomization
[SDL] Requested invalid descriptor AvatarCustomization
[SDL] Requested invalid decriptor version 6 for Layer
[SDL] WARNING: Did not fully parse SDL blob! (@0xb)
[SDL] Received an update for 'Map #638_anim' using an invalid descriptor!
[SDL] Requested invalid decriptor version 6 for Layer
[SDL] WARNING: Did not fully parse SDL blob! (@0xb)

I believe that I set up the server according to the instructions, but I'm not sure whether I used the moul-scripts repository or the Gehn shard scripts as it suggests. I think that I'm really close to getting my shard up and running. Any idea what the server is complaining about?

Thanks.
Zorkmid
 
Posts: 11
Joined: Fri May 11, 2012 8:51 am

Re: Invalid Manifest

Postby Zorkmid » Fri Oct 26, 2018 4:43 am

I went back and replaced the .age, .fni and .sdl files under /opt/dirtsand with versions from moul-script. I see a number of warnings such as:
[SDL] WARNING: Did not fully parse SDL blob! (@0x14)
[SDL] Requested invalid decriptor version 1 for Teledahn

and it still generated a segmentation fault on the server:

Segfault at bin/dirtsand(+0x7362c) [0x5578aa7e762c]
from bin/dirtsand(+0x73762) [0x5578aa7e7762]
from /lib/x86_64-linux-gnu/libc.so.6(+0x3ef20) [0x7f4d5cdc8f20]
from bin/dirtsand(+0x8da1c) [0x5578aa801a1c]
from bin/dirtsand(+0x60859) [0x5578aa7d4859]
from bin/dirtsand(+0x53e57) [0x5578aa7c7e57]
from bin/dirtsand(+0x5416f) [0x5578aa7c816f]
from bin/dirtsand(+0x548dd) [0x5578aa7c88dd]
from bin/dirtsand(+0x54c54) [0x5578aa7c8c54]
from bin/dirtsand(+0x1d1a5) [0x5578aa7911a5]
from bin/dirtsand(+0x1c835) [0x5578aa790835]
from bin/dirtsand(+0x1da5d) [0x5578aa791a5d]
from bin/dirtsand(+0x1d9fe) [0x5578aa7919fe]
from bin/dirtsand(+0x1d9ce) [0x5578aa7919ce]
from /usr/lib/x86_64-linux-gnu/libstdc++.so.6(+0xbd57f) [0x7f4d5d45057f]
from /lib/x86_64-linux-gnu/libpthread.so.0(+0x76db) [0x7f4d5d7236db]
from /lib/x86_64-linux-gnu/libc.so.6(clone+0x3f) [0x7f4d5ceab88f]

Any idea what might lead to a segmentation fault?
Thanks.
Zorkmid
 
Posts: 11
Joined: Fri May 11, 2012 8:51 am

Re: Invalid Manifest

Postby Tsar Hoikas » Fri Oct 26, 2018 8:33 am

It looks like you've somehow mismatched the data from the Gehn Shard and H-uru repositories. Your client and server must match exactly, and you will need to purge the old data from the server by executing `SELECT clear_vault();` Also, you may need to apply the temporary segfault workaround described here.
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 1837
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Invalid Manifest

Postby Zorkmid » Fri Oct 26, 2018 11:34 am

Thanks. Both my client and server use the files from the master branch of the moul-scripts repository. In addition, the client uses files from a working version of a client that connects to the main URU shard [not the Gehn shard].
server
ages directory : 47 .age files
dat directory: 39 .fni files
SDL directory: 58 .sdl files

client
dat directory: 47 .age, 2 .csv, 39 .fni, 71 .loc, , 150 .p2f, 878 .prp files
SDL directory: 58 .sdl files
sfx directory: 1737 .ogg, 1115 .wav files

The .age, .fni and .sdl files in the client and server match. Isn't that sufficient for the client and server to match exactly?

Tsar Hoikas wrote:It looks like you've somehow mismatched the data from the Gehn Shard and H-uru repositories. Your client and server must match exactly, and you will need to purge the old data from the server by executing `SELECT clear_vault();` Also, you may need to apply the temporary segfault workaround described here.
Zorkmid
 
Posts: 11
Joined: Fri May 11, 2012 8:51 am

Re: Invalid Manifest

Postby Tsar Hoikas » Mon Oct 29, 2018 4:30 pm

Zorkmid wrote:The .age, .fni and .sdl files in the client and server match. Isn't that sufficient for the client and server to match exactly?


That's correct. I missed that you had already fixed the potential mismatch -- sorry! The segmentation fault ought to be fixed by the small code change that I linked to in my previous post.
Image
User avatar
Tsar Hoikas
Councilor of Technical Direction
 
Posts: 1837
Joined: Fri Nov 16, 2007 9:45 pm
Location: South Georgia

Re: Invalid Manifest

Postby Zorkmid » Mon Oct 29, 2018 7:30 pm

Very nice! That resolved my problem, so the game now works. I went to Gahreesen for my Ki, but that didn't work. I assume that I have to meet Zandi and listen to Yeesha before I can get my Ki. Once I've played with it a while, then I'll have to consider what I can do with the development environment.

Thanks a bunch.

Tsar Hoikas wrote:
Zorkmid wrote:The .age, .fni and .sdl files in the client and server match. Isn't that sufficient for the client and server to match exactly?


That's correct. I missed that you had already fixed the potential mismatch -- sorry! The segmentation fault ought to be fixed by the small code change that I linked to in my previous post.
Zorkmid
 
Posts: 11
Joined: Fri May 11, 2012 8:51 am

Next

Return to Building

Who is online

Users browsing this forum: No registered users and 3 guests