Start Options

General debates and discussion about the Guild of Writers and Age creation

Start Options

Postby J'Kla » Thu Jul 26, 2018 12:02 am

Consider I am running a Korman Export on a LAN based dirtsand shard.

Is there any way to force this to open in an age other than Relto and then Make Panic Relto or Book return to Relto return to thatt New Start Age?

I would still need a way to get to relto or an alternative way to access Avatar Customization and Nexus and in fact an access to Nexus could provide that route to Relto.
User avatar
Posts: 1000
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK

Re: Start Options

Postby Deledrius » Thu Jul 26, 2018 2:16 am

This can be done, but I believe it would require the use of a custom client, as the general panic-link destination age is hard-coded in the engine. The change might be pretty small, but it's not something you can change at runtime as far as I know.
User avatar
Gehn Shard Admin
Posts: 1377
Joined: Mon Oct 01, 2007 1:21 pm

Re: Start Options

Postby J'Kla » Thu Jul 26, 2018 3:53 am

I am working on a Minimalist installation of the client for the LAN dirtsand.

I am runing my Avatar in a customised T-Shirt

So far from the base directory I have removed


From the avi sub folder I have removed the two .bik files

From the dat subfolder I have removed all references to the following

Baron City Office
Custom Avatars
Eder Delin
Eder Tsogal
Garden Age
Great Tree Pub
Great Zero
Guild Pubs all of them
Pellet Bahro Cave

I have also removed
All of the ACA.loc files
all non English.loc files for

Note I presume if you are working in another language you would keep that language and loose the English.

I have so far kept
Those .loc files that specify English.

Because I have removed links to the Neighborhood and Cleft there is no route to pick up the KI from Gahreesen but the typing still appears to produse communication text although I have yet to test this with a second avatar. Plus we no longer have the KI theres no icon for it at the bottom of the screen and [F2] has no action there is still a >chat at the bottom of the screen and this will bring up the chat cursor.

Obviously I have no access to those KI tools that change the Font size, its Persistence and infact all of the KI subtools

I am in the process of trying to strip out the fonts although my first atempt resulted in failure.

At one point I had a popup over screen with some audio options I had no idea how this appeared or how to switch it on/off I presume there is some sort of a toggle like the plasma console. I got rid of it by restarting the client, I suppose thats another one for investigation. :) [FOUND IT the "L" key on an empty like toggles through the various log options it must be that I have never tried to start a conversation with an L]

I presume there is some way of disabling the Plasma Console if I set up the default to my age and eventually have links within that age to other ages of my creation especialy since I have removed the Nexus links.

The hope is to create a method of running the game engine where the only age we access is the Avatar Customization and even that loses mention of Uru.

I would also hope to have a start with a different background and I know this is posible because this has been done for the Ghen Shard.

At present I still have the Pillar that has the link to Cleft and the Linking book for the Neighborhood even if these links cause the game to say it is linking to those locations but never getting there.

If we do get this to start in a fan age and get subsequent panic and relto links to cycle back to the fan age then both of those links could be dropped as the Personal age will no longer exist provided we can find some way to get to Avatar Customization and have that drop out back to the fan created base level age.

I presume there is some Plasma Console route but thats just something else I will need to investigate and I will need another route/method if I disable Plasma Console. ;)

As an experiment I stripped a load of stuff rom the Python sub-directory and ended up with a stuffed bookcase that would not click to close up, a bit like the philsRelto bookcase
this is an ok alternative as this closes out the accidental Neighborhood selection, but whatever I have done its also stopped the scroll up options from the bottom of the screen.

I am about to see if the Pillar has stopped working as well. :)

Yes the pillar is disabled but I have noticed the zero symbol texture is missing from the tabs at the bottom of each book at the moment this is cosmetic and I am sure if I can establish the Python code responsible we could make this full non active bookcase a feature.

The Avatar Customization closet is still valid and I will hack out a lisiting of the Python files I have removed and post that here as well.

List of removed python files

I suspect our two likely culprits are

I suspect there are a load of SDL files I can strip from that sub-directory and also a load of .ogg files that can also be removed from the sfx folder.

Yes the first one makes the Bahro Pole work and the second one tinkers with the bookshelf

But it must be another one that restores the popup options at the bottom of the screen.
User avatar
Posts: 1000
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK

Re: Start Options

Postby J'Kla » Thu Jul 26, 2018 8:25 am

OK Heres a Hackers Hack

Made a copy of my age Abmortoxas.blend and named it Personal.blend

Set the Sequence Prefix to 13 the code for the Personal Age

Exported the age

Went to my Minamalist install removed Personal.age and its partner files

Copied in my new exported personal.age

Fired up and I now start in my new personal age that happens to look like my Abmortoxas age

Panic Link drops me back there

Plasma Console command

net.linktoage AvatarCustomzation

Drops me into the customization page Explore Uru button puts me back in My new personal (abmortoxas) age :D

I created a clickable object in my age and set this up to link to AvatarCustomization the return link returns to my new Personal Age however when it returns I loose the text option and the menus that pop up at the bottom of the screen.

However any changes to the avatar persist through a restart and the popups are available again after that restart even if I have to use [Alt][F4] to exit.

At first I thought the lack of communication and menu links at the bottom of the screen was because of somme of the removed python but I built a version where all the Python was there and it still did it I had to replace the audio because the book made a noise like it was passing gas (farting) when you opened it. I dare say all I need to find out is the specific noise for that event or just isable all audio.

For the time being I will move my avatar customization link into a hidden area that can only be accessed by flymode once avatars are sorted it is not somthing thats needed frequently.
User avatar
Posts: 1000
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK

Re: Start Options

Postby J'Kla » Thu Aug 02, 2018 3:05 am

I just did an experiment where I put this back to its original Abmortoxas Prefix Sequence and re-exported as Personal.age

It worked just the same so it does not have to be the Personal.age prefix sequence as long as there is not another age with the same prefix sequence in the instance you are running

Saying that as this is the personal age I am probably going to keep this on the 13 prefix sequence as this will prevent accidents should I decide to add in my original Abmortoax.age.
User avatar
Posts: 1000
Joined: Wed Feb 20, 2008 3:16 pm
Location: Geordieland UK

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest